Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Failing upgrade: Parameter original_stack has invalid value: HDP-2.4. The cluster is currently on stack HDP-2.5

avatar
New Member

I've already upgraded from HDP-2.4 to HDP-2.5, but for some reason there is another upgrade process "stuck".

Since the cluster is already on HDP-2.5, it fails with the following error message:

Params: Data_PROD HDP-2.4 HDP-2.5 2.5.3.0-37 upgrade nonrolling-upgrade-2.5
Checking if can update the Desired Stack Id to HDP-2.5. The cluster's current Stack Id is HDP-2.5
Parameter original_stack has invalid value: HDP-2.4. The cluster is currently on stack HDP-2.5, HDP-2.5, yet the parameter to this function indicates a different value.

So how do I resolve this?

  • How do I cancel this upgrade?
  • or mark it as completed in the database?
  • Or change the params from HDP-2.4 to HDP-2.5 and let it continue?

Since it's in this state of Upgrade, it doesn't allow me to install new services/clients.

Related to : https://community.hortonworks.com/questions/84554/ambari-242-trying-to-upgrade-hdp-353-to-same-versi...

1 ACCEPTED SOLUTION

avatar
New Member

Resolved. Cleaned up the database references to that upgrade. (did a backup before)

View solution in original post

3 REPLIES 3

avatar
Super Guru
@Marco Silva

Can you pass me output of below command -

Login to ambari DB and execute -

ambari=> select * from clusters ;

avatar
New Member

@Sagar Shimpi

clusters:

13277-screen-shot-2017-03-06-at-132606.png

Stack.

13278-screen-shot-2017-03-06-at-132624.png

avatar
New Member

Resolved. Cleaned up the database references to that upgrade. (did a backup before)