Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-31-2016 01:00 PM
I am seeing the following error message when performing the single node Metron setup using Vagrant. I've repeated the process and can confirm the issue happens each time.
TASK: [ambari_common | Add key pairs to existing authorized_keys] *************
fatal: [node1] => could not locate file in lookup: /tmp/keys/{{ item }}.pub
FATAL: all hosts have already failed -- aborting
PLAY RECAP ********************************************************************
to retry, use: --limit @/Users/tbenton/metron_full_install.retry
node1 : ok=9 changed=8 unreachable=1 failed=0
Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.
Created 04-12-2016 08:36 PM
Upgrading to Ansible 2.0+ fixed the issue here. I am able to continue the build now after upgrading. It was likely due to an older version of Ansible that I had installed.
Created 03-31-2016 01:08 PM
Hey Tom,
Thanks for trying out metron, first off 🙂 Anything going on before that log? Also, what's your platform and version of vagrant installed?
Created 04-01-2016 12:21 PM
Everything else is showing success through the mvn apache-rat and integration-test. I only get an error at this point.
Mac OS X 10.11.4
Vagrant 1.8.1
VirtualBox 5.0.16
Created 04-01-2016 03:02 PM
Log output from ansible-playbook run
==> node1: Running provisioner: ansible...
node1: Running ansible-playbook...
PLAY [ec2] ********************************************************************
skipping: no hosts matched
PLAY [ambari_*] ***************************************************************
GATHERING FACTS ***************************************************************
ok: [node1]
TASK: [libselinux-python | Install libselinux-python] *************************
changed: [node1]
TASK: [yum-update | Yum Update Packages] **************************************
changed: [node1]
TASK: [epel | Get epel-repo rpm] **********************************************
changed: [node1]
TASK: [epel | Install epel-repo rpm] ******************************************
changed: [node1]
TASK: [ntp | Install ntp] *****************************************************
changed: [node1]
TASK: [ntp | Ensure ntp is running and enabled] *******************************
changed: [node1]
TASK: [ambari_common | Check OS Version] **************************************
skipping: [node1]
TASK: [ambari_common | Generate ssh key pair for "root"] **********************
changed: [node1]
TASK: [ambari_common | Fetch the generated public key] ************************
changed: [node1]
TASK: [ambari_common | Add key pairs to existing authorized_keys] *************
fatal: [node1] => could not locate file in lookup: /tmp/keys/{{ item }}.pub
FATAL: all hosts have already failed -- aborting
PLAY RECAP ********************************************************************
to retry, use: --limit @/Users/tbenton/metron_full_install.retry
node1 : ok=9 changed=8 unreachable=1 failed=0
Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.
Created 04-04-2016 04:20 PM
HI Tom,
I have a couple of questions- can you give me your ansible --version from your Mac and the top hash from the git log?
Also - after it gives the error, was anything left in /tmp/keys?
Thanks!
-David...
Created 04-06-2016 11:01 PM
tbenton$ ansible --version
ansible 1.9.0.1
configured module search path = None
[vagrant@node1 ~]$ ls /tmp
epel-release.rpm hosts ks-script-u_G5MN ks-script-u_G5MN.log vboxguest-Module.symvers yum.log
which git log did you want the hash from?
Created 04-12-2016 08:36 PM
Upgrading to Ansible 2.0+ fixed the issue here. I am able to continue the build now after upgrading. It was likely due to an older version of Ansible that I had installed.