Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Failure while adding new hadoop services through Ambari.

avatar
Expert Contributor

Ambari throws error while adding new services as below

[ambari-client-thread-47469] AbstractResourceProvider:97 - Error occured during recommendation 
org.apache.ambari.server.api.services.stackadvisor.StackAdvisorException: Error occured during stack advisor command invocation: Cannot create /var/run/ambari-server/stack-recommendations
1 ACCEPTED SOLUTION

avatar
Rising Star

@nyadav

The permission for /var/run/ambari/server should be setup correctly

ll /var/run/ambari-server/

total 12
-rw-r--r--  1 root root    6 Jan  4 05:10 ambari-server.pid
drwxr-xr-x  4 root root 4096 Jan  4 05:26 bootstrap
drwxr-xr-x 39 root root 4096 Jan     17 18:14 stack-recommendations


Check and correct your permissions and try again.

View solution in original post

2 REPLIES 2

avatar
Rising Star

@nyadav

The permission for /var/run/ambari/server should be setup correctly

ll /var/run/ambari-server/

total 12
-rw-r--r--  1 root root    6 Jan  4 05:10 ambari-server.pid
drwxr-xr-x  4 root root 4096 Jan  4 05:26 bootstrap
drwxr-xr-x 39 root root 4096 Jan     17 18:14 stack-recommendations


Check and correct your permissions and try again.

avatar
Expert Contributor

Thanks @prsingh, able to add service after correcting the permission