Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-14-2018 11:13 PM
HDP Version: 2.6.4.0
Falcon Version: 0.10.0
Ambari Version: 2.6.2.2
We are having problems with Falcon Server. Alert in the Ambari Dashboard is:
HTTP 503 response from http://aforge021:15000 in 0.000s (HTTP Error 503: Service Unavailable)
Error in /var/log/falcon on Falcon server:
2018-08-13
16:57:22,672 ERROR - [main:] ~ Failed startup of context
org.mortbay.jetty.webapp.WebAppContext@34e260e{/,/usr/hdp/current/falcon-server/server/webapp/falcon}
(log:87)java.lang.RuntimeException:
org.apache.falcon.FalconException: Unable to get instance for
org.apache.atlas.falcon.service.AtlasService at
org.apache.falcon.listener.ContextStartupListener.contextInitialized(ContextStartupListener.java:59) at
org.mortbay.jetty.handler.ContextHandler.startContext(ContextHandler.java:549) at
org.mortbay.jetty.servlet.Context.startContext(Context.java:136) at
org.mortbay.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1282) at
org.mortbay.jetty.handler.ContextHandler.doStart(ContextHandler.java:518) at
org.mortbay.jetty.webapp.WebAppContext.doStart(WebAppContext.java:499) at
org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50) at
org.mortbay.jetty.handler.HandlerWrapper.doStart(HandlerWrapper.java:130) at
org.mortbay.jetty.Server.doStart(Server.java:224) at
org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50) at
org.apache.falcon.util.EmbeddedServer.start(EmbeddedServer.java:58) at
org.apache.falcon.FalconServer.main(FalconServer.java:118)Caused
by: org.apache.falcon.FalconException: Unable to get instance for
org.apache.atlas.falcon.service.AtlasService at
org.apache.falcon.util.ReflectionUtils.getInstanceByClassName(ReflectionUtils.java:52) at
org.apache.falcon.service.ServiceInitializer.initialize(ServiceInitializer.java:43) at
org.apache.falcon.listener.ContextStartupListener.contextInitialized(ContextStartupListener.java:56) ... 11 moreCaused
by: java.lang.ClassNotFoundException:
org.apache.atlas.falcon.service.AtlasService at
java.net.URLClassLoader.findClass(URLClassLoader.java:381) at
java.lang.ClassLoader.loadClass(ClassLoader.java:424) at
sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331) at
java.lang.ClassLoader.loadClass(ClassLoader.java:357) at
org.apache.falcon.util.ReflectionUtils.getInstanceByClassName(ReflectionUtils.java:44) ... 13 moreOriginally when the cluster and falcon were installed it did not have the Berkeley DB installed. After searching my error messages I found that this was needed and installed it using the steps outlined in this post:
https://community.hortonworks.com/questions/11862/falcon-ui-not-working.html
But after installing the Berkeley DB I still have the same error. I have also tried deleting the Falcon service in Ambari, redoing the steps to install Berkeley DB, and then re-installing Falcon, but the same error remains.
Created 08-16-2018 07:05 AM
Please check if atlas client is installed in the falcon machine. If the client is installed and still seeing the issue.
Check if atlas is mapped to the correct hdp version using below command.
>>>hdp-select | grep atlas atlas-client - 2.6.4.0-91 atlas-server - 2.6.4.0-91
Created 08-16-2018 07:05 AM
Please check if atlas client is installed in the falcon machine. If the client is installed and still seeing the issue.
Check if atlas is mapped to the correct hdp version using below command.
>>>hdp-select | grep atlas atlas-client - 2.6.4.0-91 atlas-server - 2.6.4.0-91
Created 08-16-2018 02:22 PM
Atlas client was not installed on the Falcon Server. After installing the atlas client I can now access the Falcon Web UI. Thank you!