Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Falcon feed throwing an error during feed schedule ERROR: Bad Request;default/E0803 : E0803: IO error, null

avatar
Guru

I am trying schedule falcon feed and getting following error.

Note: It is giving an error after I tried to run falcon cluster on NN HA. and it was running fine if I do not make Namenode HA in falcon cluster.

falcon entity -type feed -name replicationFeed2 -schedule

ERROR: Bad Request;default/E0803 : E0803: IO error, null

CausedBy: E0803: IO error, null

Following is falcon logs error.

2017-04-24 06:09:45,351 ERROR - [1068218748@qtp-461591680-39 - aaa42726-6436-4d13-ad2f-7576deb01baf:s0998dnz:POST//entities/schedule/feed/replicationFeed2] ~ Entity schedule failed for feed: replicationFeed2 (AbstractSchedulableEntityManager:104)

org.apache.falcon.FalconException: E0803 : E0803: IO error, null

at org.apache.falcon.workflow.engine.OozieWorkflowEngine.dryRunInternal(OozieWorkflowEngine.java:252)

at org.apache.falcon.workflow.engine.OozieWorkflowEngine.schedule(OozieWorkflowEngine.java:181)

1 ACCEPTED SOLUTION

avatar
Guru

There was a missing configuration in source cluster in oozie service.

oozie.service.HadoopAccessorService.hadoop.configurations=*={{hadoop_conf_dir}},m1.hdp22:8050=/hdptmp/testconfig,m2.hdp22:8050=/hdptmp/testconfig,m1.hdp22:8020=/hdptmp/testconfig,m2.hdp22:8020=/hdptmp/testconfig

View solution in original post

2 REPLIES 2

avatar
Expert Contributor

Did you configure Falcon for HA according to these instructions?

avatar
Guru

There was a missing configuration in source cluster in oozie service.

oozie.service.HadoopAccessorService.hadoop.configurations=*={{hadoop_conf_dir}},m1.hdp22:8050=/hdptmp/testconfig,m2.hdp22:8050=/hdptmp/testconfig,m1.hdp22:8020=/hdptmp/testconfig,m2.hdp22:8020=/hdptmp/testconfig