Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 11-21-2016 09:05 PM
CDH Parcels Distributed sucessfully, but its not getting activated. When i checked cloudera-scm-agent logs, below is the error i'm getting
[22/Nov/2016 10:13:14 +0000] 42787 MainThread agent ERROR Failed to configure inotify. Parcel repository will not auto-refresh.
Traceback (most recent call last):
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.7.0-py2.7.egg/cmf/agent.py", line 776, in _init_after_first_heartbeat_response
self.inotify = self.repo.configure_inotify()
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.7.0-py2.7.egg/cmf/parcel.py", line 407, in configure_inotify
wm = pyinotify.WatchManager()
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/pyinotify-0.9.3-py2.7.egg/pyinotify.py", line 1706, in __init__
raise OSError(err % self._inotify_wrapper.str_errno())
OSError: Cannot initialize new instance of inotify, Errno=Too many open files (EMFILE)
[22/Nov/2016 10:13:14 +0000] 42787 MainThread parcel_cache INFO Using /opt/cloudera/parcel-cache for parcel cache
[22/Nov/2016 10:13:15 +0000] 42787 MainThread agent ERROR Caught unexpected exception in main loop.
Traceback (most recent call last):
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.7.0-py2.7.egg/cmf/agent.py", line 673, in start
self._init_after_first_heartbeat_response(heartbeat_response["data"])
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.7.0-py2.7.egg/cmf/agent.py", line 803, in _init_after_first_heartbeat_response
self.client_configs.load()
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.7.0-py2.7.egg/cmf/client_configs.py", line 682, in load
new_deployed.update(self._lookup_alternatives(fname))
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.7.0-py2.7.egg/cmf/client_configs.py", line 432, in _lookup_alternatives
return self._parse_alternatives(alt_name, out)
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.7.0-py2.7.egg/cmf/client_configs.py", line 444, in _parse_alternatives
path, _, _, priority_str = line.rstrip().split(" ")
ValueError: too many values to unpackAny help to fix the issue
Created 11-22-2016 02:34 AM
Created on 11-21-2016 09:55 PM - edited 11-21-2016 09:59 PM
I restarted the server and for 10 mins i didn't get Too many opend files issue, again its started. Now it is showing below along with above issue
[22/Nov/2016 11:22:45 +0000] 5583 MainThread agent ERROR Caught unexpected exception in main loop.
Traceback (most recent call last):
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.7.0-py2.7.egg/cmf/agent.py", line 673, in start
self._init_after_first_heartbeat_response(heartbeat_response["data"])
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.7.0-py2.7.egg/cmf/agent.py", line 803, in _init_after_first_heartbeat_response
self.client_configs.load()
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.7.0-py2.7.egg/cmf/client_configs.py", line 682, in load
new_deployed.update(self._lookup_alternatives(fname))
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.7.0-py2.7.egg/cmf/client_configs.py", line 432, in _lookup_alternatives
return self._parse_alternatives(alt_name, out)
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.7.0-py2.7.egg/cmf/client_configs.py", line 444, in _parse_alternatives
path, _, _, priority_str = line.rstrip().split(" ")
ValueError: too many values to unpack
Created 11-22-2016 02:34 AM
Created on 06-07-2017 04:31 AM - edited 06-07-2017 04:33 AM
Uninstalling OpenJDK solved it for me aswell. These packages were installed with Trifacta unfortunately in my case.
Created 11-28-2017 02:01 AM
Same for me! Trifacta should know better! 🙂 Is openJDK still a requirement for Trifacta?
Created 04-08-2019 05:55 PM
Hi,
Could you please let me know how did you resolve this. I have the same issue. I have checked for jdk, but its the same in all the other servers as well. Not sure why there is issue with only 1 server
[root@ip-xx-x-xx-x cloudera-scm-agent]# rpm -qa "*jdk*"
java-1.8.0-openjdk-devel-1.8.0.144-0.b01.el7_4.x86_64
java-1.8.0-openjdk-headless-1.8.0.144-0.b01.el7_4.x86_64
jdk1.8.0_102-1.8.0_102-fcs.x86_64
copy-jdk-configs-2.2-3.el7.noarch
java-1.8.0-openjdk-1.8.0.144-0.b01.el7_4.x86_64
Thanks