Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-02-2016 06:25 PM
So we have a kerberized cluster and have integrated ldaps with zeppelin. But when i try to use livy i get the following error
ERROR [2016-12-01 10:00:02,442] ({pool-2-thread-4} LivyHelper.java[createSession]:128) - Error getting session for user java.lang.Exception: Cannot start spark. at org.apache.zeppelin.livy.LivyHelper.createSession(LivyHelper.java:117) at org.apache.zeppelin.livy.LivySparkSQLInterpreter.interpret(LivySparkSQLInterpreter.java:62) at org.apache.zeppelin.interpreter.LazyOpenInterpreter.interpret(LazyOpenInterpreter.java:94) at org.apache.zeppelin.interpreter.remote.RemoteInterpreterServer$InterpretJob.jobRun(RemoteInterpreterServer.java:341) at org.apache.zeppelin.scheduler.Job.run(Job.java:176) at org.apache.zeppelin.scheduler.FIFOScheduler$1.run(FIFOScheduler.java:139) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) at java.lang.Thread.run(Thread.java:745) ERROR [2016-12-01 10:00:02,442] ({pool-2-thread-4} LivySparkSQLInterpreter.java[interpret]:70) - Exception in LivySparkSQLInterpreter while interpret java.lang.Exception: Cannot start spark.
in zeppelin interpreter logs.
Also when i dont enable ldap for zeppelin (that is i log in as anonymous), I can see that job is been submitted to yarn but it fails as user is `zeppelin-clusterName`. But when i use ldap with zeppelin it is not even getting submit to yarn.
Created 12-14-2016 06:38 PM
So guys @kbadani and @jzhang the issue finally got solved and thank you for your support. It was very trivial but very important property, livy.superuser was set to `zeppelin-<cluster name in uppercase>` but the principal was in lower case 😛 . And changing that solved the issue, @kbadani You pointed out that property but I didnt know that it is case sensitive.
Created 12-03-2016 11:20 AM
Do you kerberos your cluster using ambari ? There're serveral configuration you need to make it work.
Created 12-03-2016 01:14 PM
Hey @jzhang, thanks for the interest. Yes, i have used ambari for kerberization and also i have set proxy users property for livy in hdfs
Created 12-03-2016 11:35 PM
The session might be expired, Can you restart livy interpreter ? And if you still get the error, check the RM UI to find the yarn app log.
Created 12-06-2016 12:01 PM
@jzhang, So i did restart the server and checked yarn logs but the job is not getting submitted, I cannot see any submitted or failed jobs.
Created 12-06-2016 12:59 PM
Do you run it in yarn-cluster mode ? Set livy.spark.master as yarn-cluster in interpreter setting page
Created 12-06-2016 01:21 PM
yes i have already set that to yarn-cluster mode
Created 12-07-2016 06:29 PM
@Bhavin Tandel Have you setup livy.superusers property to your zeppelin principal in livy.conf?
Created 12-07-2016 06:42 PM
yes, i have set it to zeppelin principal. But just for heads up i have not configured ldap for MIT Kerberos but i am using ldap with zeppelin.
Created 12-08-2016 06:42 PM
@Bhavin Tandel please ensure you have all of the following setup
1) when you try to login using ldap - the user you are getting logged in has corresponding data directory on HDFS (/user/xyz) ? Also, the unix user should be present on the cluster
2) livy.superusers = zeppelin-clustername in livy.conf (which you already have done)
3) Along with for 'livy' user, also please setup proxy permissions for both 'zeppelin' and 'zeppelin-clustername' in HDFS core-site.xml
hadoop.proxyuser.zeppelin.hosts = * hadoop.proxyuser.zeppelin.hosts = * hadoop.proxyuser.zeppelin-clustername.hosts = * hadoop.proxyuser.zeppelin-clustername.hosts = *