Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 05-10-2017 10:20 AM - edited 09-16-2022 04:35 AM
We have two secure cluster with kerbores. While doing distcp getting following error.
Error:-
Caused by: GSSException: No valid credentials provided (Mechanism level: Server not found in Kerberos database (7) - UNKNOWN_SERVER) at sun.security.jgss.krb5.Krb5Context.initSecContext(Krb5Context.java:710) at sun.security.jgss.GSSContextImpl.initSecContext(GSSContextImpl.java:248) at sun.security.jgss.GSSContextImpl.initSecContext(GSSContextImpl.java:179) at com.sun.security.sasl.gsskerb.GssKrb5Client.evaluateChallenge(GssKrb5Client.java:193) ... 38 more Caused by: KrbException: Server not found in Kerberos database (7) - UNKNOWN_SERVER at sun.security.krb5.KrbTgsRep.<init>(KrbTgsRep.java:73) at sun.security.krb5.KrbTgsReq.getReply(KrbTgsReq.java:192) at sun.security.krb5.KrbTgsReq.sendAndGetCreds(KrbTgsReq.java:203) at sun.security.krb5.internal.CredentialsUtil.serviceCreds(CredentialsUtil.java:311) at sun.security.krb5.internal.CredentialsUtil.acquireServiceCreds(CredentialsUtil.java:115) at sun.security.krb5.Credentials.acquireServiceCreds(Credentials.java:449) at sun.security.jgss.krb5.Krb5Context.initSecContext(Krb5Context.java:641) ... 41 more Caused by: KrbException: Identifier doesn't match expected value (906) at sun.security.krb5.internal.KDCRep.init(KDCRep.java:143) at sun.security.krb5.internal.TGSRep.init(TGSRep.java:66) at sun.security.krb5.internal.TGSRep.<init>(TGSRep.java:61) at sun.security.krb5.KrbTgsRep.<init>(KrbTgsRep.java:55)
Created 05-11-2017 11:30 AM
@Bala Vignesh N V
I have found the acurate issue. Issue was kerberos cross realm. I have configured cross realm:-
https://community.hortonworks.com/articles/18686/kerberos-cross-realm-trust-for-distcp.html
Created 05-10-2017 07:33 PM
As the log says that the provided credentials were unable to be identified.
Causes may fall under any of the below:
Refer the link for the solution on how to overcome this.
Hope it help in solving your issue.
Created 05-11-2017 11:30 AM
@Bala Vignesh N V
I have found the acurate issue. Issue was kerberos cross realm. I have configured cross realm:-
https://community.hortonworks.com/articles/18686/kerberos-cross-realm-trust-for-distcp.html
Created 05-11-2017 12:23 PM
@Ashnee Sharma
Good article. Thanks for sharing!