Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-07-2016 10:46 AM
I set the property in hbase for pheniox userd defined funtion to true but still getting the error for the same.:-
phoenix.functions.allowUserDefinedFunctions = true
Command to connect pheonix:-
Command to connect:-
/usr/hdp/2.3.2.0-2950/phoenix/bin/sqlline.py localhost:2181:/hbase-unsecure
CREATE FUNCTION jsonstring(varchar,varchar) returns varchar as 'com.xyz.accesslayer.GetStringFrom Json';
Error: ERROR 6003 (42F03): User defined functions are configured to not be allowed. To allow configure phoenix.functions.allowUserDefinedFunctions to true. (state=42F03,code=6003)
Created 06-07-2016 11:11 AM
Issue is resolved after coping the updated hbase-sites.xml
cp -r <HBASE_CONFIG_DIR>/hbase-site.xml <PHOENIX_HOME>/bin/hbase-site.xml
Thanks fro imidiate reply.
Created 06-07-2016 11:01 AM
Restart the HBase Master and Region Servers.
Created 06-07-2016 11:03 AM
I have restarted with all settings.
Created 06-07-2016 11:11 AM
Issue is resolved after coping the updated hbase-sites.xml
cp -r <HBASE_CONFIG_DIR>/hbase-site.xml <PHOENIX_HOME>/bin/hbase-site.xml
Thanks fro imidiate reply.
Created 06-07-2016 11:30 AM
Are you using Ambari to change these parameter or manually adding it?
Created 06-09-2016 06:05 AM
@Jitendra Yadav,
No I am doing changes from ambari web UI.