Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 09-24-2016 03:29 AM - edited 09-16-2022 03:40 AM
I am running clusterdock on Fedora Core 23. When I issue the command
clusterdock_run ./bin/start_cluster cdh
I get the following error when the nodes are images are being pulled.
INFO:clusterdock.topologies.cdh.actions:Pulling image docker.io/cloudera/clusterdock:cdh580_cm581_primary-node. This might take a little while... Warning: failed to get default registry endpoint from daemon (Error response from daemon: client is newer than server (client API version: 1.23, server API version: 1.22)). Using system default: https://index.docker.io/v1/ Error response from daemon: client is newer than server (client API version: 1.23, server API version: 1.22) Fatal error: local() encountered an error (return code 1) while executing 'docker pull docker.io/cloudera/clusterdock:cdh580_cm581_primary-node' Aborting.
I can continue by manually pulling the images but will I see this error every time?
Created 09-24-2016 07:34 AM
Created 09-24-2016 04:19 AM
Created 09-24-2016 07:34 AM
Created 09-24-2016 08:14 AM
Thanks.
I followed the solution at Docker Installation On Fedora to install Docker's own yum repo. This allowed to me to upgrade to 1.12 and the clusterdock solution worked after that.