Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-26-2016 09:24 AM
File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call raise Fail(err_msg) resource_management.core.exceptions.Fail: Execution of '/usr/sbin/ambari-metrics-grafana start' returned 1. Starting Ambari Metrics Grafana: .... FAILED
Created 08-31-2016 01:50 PM
On troubleshooting found the solution:
We were installing Ambari Metrics as customised user and the permission on /var/lib/ambari-metrics-grafana directory was owned by root.
we changed the ownership of directory to customised grafana user/group and after that grafana service was started.
It can be checked on server as netstat -nlp | grep 3000
Created 08-26-2016 06:17 PM
Hi Jigar,
Can you check if a Grafana instance is already running on that host, and Ambari is not picking it up?
ps aux | grep grafana
If it is running, please check if cat /var/run/ambari-metrics-grafana/grafana-server.pid matches the process id.
If it is not running, please share the Grafana logs (/var/log/ambari-metrics-grafana/*)
Created on 03-22-2017 12:51 PM - edited 08-19-2019 03:28 AM
I'm experiencing the same problem with jigar. I checked it using your stated command and here's the result.
It seems that it doesn't match the pid.
Created 08-31-2016 01:50 PM
On troubleshooting found the solution:
We were installing Ambari Metrics as customised user and the permission on /var/lib/ambari-metrics-grafana directory was owned by root.
we changed the ownership of directory to customised grafana user/group and after that grafana service was started.
It can be checked on server as netstat -nlp | grep 3000
Created 03-22-2017 08:14 PM
@Bruce Perez This intermittent issue is fixed in Ambari 2.5.0 - https://issues.apache.org/jira/browse/AMBARI-19054.
Please change the pid file to match the actual PID.
echo 31695 > /var/run/ambari-metrics-grafana/grafana-server.pid
Created 03-23-2017 03:20 AM
: Thanks! it fixes my issue.