Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 11-08-2016 05:38 AM
NoMethodError: undefined method `getTerminal' for Java::Jline::Terminal:Module
refresh_width at /usr/hdp/2.5.0.0-1245/hbase/lib/ruby/shell/formatter.rb:33
initialize at /usr/hdp/2.5.0.0-1245/hbase/lib/ruby/shell/formatter.rb:46
(root) at /usr/hdp/2.5.0.0-1245/hbase/bin/hirb.rb:128
-------------------------------------------------------------------------------
I found it required higher version of protobuf jar so I updated HBase lib by replacing to protobuf-java-3.1.0.jar from protobuf-java-2.5.0.jar, still facing same error.
Created 11-08-2016 05:44 AM
Did you make any changes in the hbase classpath or any new jars added to the lib directory? It seems that you have wrong jline there.
Created 11-08-2016 11:20 AM
For example you can refer to the following link which says that lots of methods have been removed between 2.5 and 3.0 version of Protobuf-java
https://abi-laboratory.pro/java/tracker/timeline/protobuf-java/
You can get the details by clicking on the "Removed Methods" and "Added Methods" links
Created 11-08-2016 08:04 PM
Hbase in HDP-2.5 will NOT work with protobuf-3.0. Please refrain from manually changing libraries or classpath entries of any of the HDP components.
Created 11-17-2016 10:04 AM
I have HDP2.5, I changed protobuf-3.0 with default one.
Created 11-14-2016 11:50 PM
cat /etc/hbase/conf/hbase-site.xml |grep -1 hbase.tmp, please make sure chmod 777 to hbase.tmp.dir . Things should work after same.
Created 11-23-2016 06:31 AM
[root@HDCLUS01-HOST6 lib]# cat /etc/hbase/conf/hbase-site.xml |grep -1 hbase.tmp
<name>hbase.local.dir</name>
<value>${hbase.tmp.dir}/local</value>
</property>
--
<property>
<name>hbase.tmp.dir</name>
<value>/tmp/hbase-${user.name}</value>
----------------------------------------------------------- As mentioned above I provide chmod 777, but my bad still getting same error
Created 11-23-2016 06:36 AM
I changed jruby-complete-1.7.4.jar to jruby-complete-1.6.8 in /hbase/lib, I tried to restart HBase but not Hmaster is stopped with "Connection refused to hdclus01-host6:16000"