Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

HDFS not start ( after new cluster installation )

avatar

we installed new HDP cluster version 2.6

meanwhile HDFS and yarn are down and when we start the HDFS we get:

2017-10-23 16:39:35,510 ERROR datanode.DataNode (DataNode.java:secureMain(2691)) - Exception in secureMain org.apache.hadoop.util.DiskChecker$DiskErrorException: Too many failed volumes - current valid volumes: 0, volumes configured: 5, volumes failed: 5, volume fail ures tolerated: 0 at org.apache.hadoop.hdfs.server.datanode.checker.StorageLocationChecker.check(StorageLocationChecker.java:216) at org.apache.hadoop.hdfs.server.datanode.DataNode.makeInstance(DataNode.java:2583) at org.apache.hadoop.hdfs.server.datanode.DataNode.instantiateDataNode(DataNode.java:2492) at org.apache.hadoop.hdfs.server.datanode.DataNode.createDataNode(DataNode.java:2539) at org.apache.hadoop.hdfs.server.datanode.DataNode.secureMain(DataNode.java:2684) at org.apache.hadoop.hdfs.server.datanode.DataNode.main(DataNode.java:2708) 2017-10-23 16:39:35,512 INFO util.ExitUtil (ExitUtil.java:terminate(124)) - Exiting with status 1 2017-10-23 16:39:35,515 INFO datanode.DataNode (LogAdapter.java:info(47)) - SHUTDOWN_MSG:

what we need to check in this case ?

Michael-Bronson
1 ACCEPTED SOLUTION

avatar
Master Mentor

@uri ben-ari

This looks like a mount issue or due to some reasons the data.dir is not readable/accessible. Can you please check from the OS side if there any disk/mount issue?

Please check for Bad Mounts. A system admin can help better in mount/disk related issues. May be looking at the "/var/log/messages" can give some idea.

Also can you please check the "dfs.datanode.data.dir" directory to findout if there is any issue. Please share value of this property and also check the permission.

.

View solution in original post

1 REPLY 1

avatar
Master Mentor

@uri ben-ari

This looks like a mount issue or due to some reasons the data.dir is not readable/accessible. Can you please check from the OS side if there any disk/mount issue?

Please check for Bad Mounts. A system admin can help better in mount/disk related issues. May be looking at the "/var/log/messages" can give some idea.

Also can you please check the "dfs.datanode.data.dir" directory to findout if there is any issue. Please share value of this property and also check the permission.

.