Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

HDP 2.3.0 Windows Server 2012 R2 Single Node Cluster: 8020 Connection Refused

avatar
New Member

Hi,

I'm a newbie in this field and trying to setup HDP 2.3.0 single node cluster on a Windows Server 2012 R2 system. I've been following the steps mentioned here: http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.3.0-Win/bk_QuickStart_HDPWin/content/ch_qinst.ht...

However, after successfully installing HDP 2.3.0 as per instructions, I was able to start the services with 2 failures:2134-hdperr1.png

After this, I went on to check one of the HDFS commands but the connection was refused:2135-hdperr2.png

Does anyone know what I've done wrong in setting up the single node cluster or do I need to do something else for this to work? Please also note that I've disabled the firewall already.

Thanks in advance for helping!

Adi

EDIT: Installing SQL server instead of Derby solved the problem. Thanks to @Artem Ervits.

1 ACCEPTED SOLUTION

avatar
Master Mentor

@Aditya Goyal this seems to be a common problem, can you retry your install with SQL server and not derby. People are having issues with derby on windows.

View solution in original post

11 REPLIES 11

avatar
Master Mentor

Please accept the answer @Aditya Goyal

avatar
Master Mentor

@Aditya Goyal

I would opt to install a MySQL server to resolve the stalemate!