Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-22-2016 01:57 PM
I've built an HDP 2.3 cluster on AWS, and using Ambari I created a view for Hive, and granted the Ambari admin login permission to that view. However, when logged in as the Ambari admin account, whenever I attempt to access that view this error message is thrown:
H060 Unable to open Hive session: org.apache.thrift.protocol.TProtocolException: Required field 'serverProtocolVersion' is unset!
in the HDFS advance configuration, custom core-site section, these properties have been set:
hadoop.proxyuser.root.hosts=*
hadoop.proxyuser.root.groups=*
hadoop.proxyuser.ec2-user.hosts=*
hadoop.proxyuser.ec2-user.groups=*
Any recommendations to remedy this error are welcome.
Created 03-24-2016 07:54 PM
The root cause of the problem has been remedied. Please consider this matter closed.
Created 03-22-2016 04:01 PM
Please look at HCC post https://community.hortonworks.com/questions/13820/ambari-hive-view-problem.htm
which is similar to issue you are expereiencing.
Created 03-22-2016 07:05 PM
@smanjee
Thanks for your recommendation, unfortunately, when browsing to that URL the 'page not found' error is remitted
Created 03-24-2016 07:54 PM
The root cause of the problem has been remedied. Please consider this matter closed.