Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-09-2016 11:22 AM
Hi,
I was trying to setup ranger-hdfs-audit plugin and I can see it's successfully audting to hdfs and DB.
However the Audit UI doesn't show any data with message 'No Access Audit found!'
In Ranger xa_portal.log I see this error
2016-08-09 06:22:40,790 [http-bio-6080-exec-3] FATAL org.apache.ranger.solr.SolrMgr (SolrMgr.java:121) - Solr ZKHosts and URL for Audit are empty. Please set property ranger.audit.solr.zookeepers or ranger.audit.solr.urls 2016-08-09 06:22:40,791 [http-bio-6080-exec-3] WARN org.apache.ranger.solr.SolrAccessAuditsService (SolrAccessAuditsService.java:127) - Solr client is null, so not running the query. 2016-08-09 06:22:40,792 [http-bio-6080-exec-3] INFO org.apache.ranger.common.RESTErrorUtil (RESTErrorUtil.java:64) - Request failed. SessionId=816, loginId=admin, logMessage=Error connecting to search engine
I have not selected Solr anywhere, Is it possible to not use Solr?
Thanks,
Avijeet
Created 08-09-2016 03:53 PM
Can you check the value of property is set to "db"-
Services-> Ranger>Configs-> Advance->"ranger.audit.source.type"
Else you can search for "solr" in filter search tab and check if you have set solr anywhere in config.
Let me know if that works.
Created on 08-09-2016 11:58 AM - edited 08-18-2019 03:47 AM
Hi @Avijeet Dash - audit to Solr is now enabled by default. You can go into Ranger Configs in Ambari and disable it using the slider button as in the screenshot below:
Created 08-09-2016 03:53 PM
Can you check the value of property is set to "db"-
Services-> Ranger>Configs-> Advance->"ranger.audit.source.type"
Else you can search for "solr" in filter search tab and check if you have set solr anywhere in config.
Let me know if that works.