Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-21-2016 09:43 PM
I had to restart my AWS server which caused it's public dns changed . so for opening the ambari-server I had to connect to new dns:8080 port, and I was able to connect easily. But when I am connecting to the hive view it is giving below error.
H060 Unable to open Hive session: org.apache.thrift.protocol.TProtocolException:Required field 'serverProtocolVersion'is unset!Struct:TOpenSessionResp(status:TStatus(statusCode:ERROR_STATUS, infoMessages:[*org.apache.
Created 02-21-2016 10:43 PM
Gracefully stop all the services using Ambari.
Restart all the services using Ambari @times after reboot of the server you will need to manually start those service that wont be started by Ambari but subsequent Ambari startall /stopall will work correctly.
Keep me posted
Created 02-21-2016 09:50 PM
If you have ambari you can add the properties via: services->HDFS->configs->advanced->custom core-site
Add the below properties
hadoop.proxyuser.hive.hosts=* hadoop.proxyuser.hive.groups=*
Than restart all the affected the services.
Created 02-21-2016 10:30 PM
I already have these property added. Let me give you the brief This were running fine until i restarted my aws server and its dns chnaged and I see these errors.
Write now I am getting below errors :
org.apache.ambari.view.hive.client.HiveClientException: H060 Unable to open Hive session: org.apache.thrift.transport.TTransportException: java.net.SocketTimeoutException: Read timed out
Created 02-21-2016 09:51 PM
Restart hive service
Created 02-21-2016 10:43 PM
Gracefully stop all the services using Ambari.
Restart all the services using Ambari @times after reboot of the server you will need to manually start those service that wont be started by Ambari but subsequent Ambari startall /stopall will work correctly.
Keep me posted
Created 02-21-2016 10:53 PM
Thank you very much for your help.. It is working now..
Will you be able to answer my question? you mentioned to add property hadoop.proxyuser.hive.hosts=* but hontor document says to add hadoop.proxyuser.root.hosts=* I have added both but not sure why and which one is working.
Created 02-22-2016 07:06 AM
Good question.. Not sure how is it related to protocol version ! at least the error message is definitely wrong. This is the only workaround I got.
The issue is related to restrict access to the Hive metastore service by allowing it to impersonate only a subset of Kerberos users. This can be done by setting the hadoop.proxyuser.hive.groups property in core-site.xml on the Hive metastore host.
The issue has something to do with org.apache.thrift.protocol client_protocol, My reasoning was to give the hive user a wildcard privilege like the root.There is a jira out there as I see it resolved your problem then you can accept it as an answer cheers!
Created 02-22-2016 07:33 AM
Created 02-24-2016 06:09 AM
Is this problem still persistent ? If my proposed solution resolved your issue then could you accept my answer !
Created 05-09-2016 01:40 AM
Hello all,
I am having a similar issue here. Everything was working fine on HIVE until I have installed HBase and Ambari Metrics services. I performed pretty much all the changes proposed on this post and the documentation and still getting the error below:
Any ideias here appreciated!
H060 Unable to open Hive session: org.apache.thrift.transport.TTransportException: java.net.SocketTimeoutException: Read timed out
org.apache.ambari.view.hive.client.HiveClientException: H060 Unable to open Hive session: org.apache.thrift.transport.TTransportException: java.net.SocketTimeoutException: Read timed out org.apache.ambari.view.hive.client.HiveClientException: H060 Unable to open Hive session: org.apache.thrift.transport.TTransportException: java.net.SocketTimeoutException: Read timed out at org.apache.ambari.view.hive.client.Connection$2.body(Connection.java:488) at org.apache.ambari.view.hive.client.Connection$2.body(Connection.java:475) at org.apache.ambari.view.hive.client.HiveCall.call(HiveCall.java:101) at org.apache.ambari.view.hive.client.Connection.openSession(Connection.java:475) at org.apache.ambari.view.hive.client.Connection.getOrCreateSessionByTag(Connection.java:523) at org.apache.ambari.view.hive.resources.browser.HiveBrowserService.databases(HiveBrowserService.java:87) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:497)