Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 09-22-2017 04:53 PM
Hi, i manually installed hadoop 2.7.4
However, namenode never start.
i can see datanode and secondrynamenode are starting.
the core_site.xml
<property> <name>hadoop.tmp.dir</name> <value>/home/hduser/tmp</value> <description>A base for other temporary directories.</description> </property> <property> <name>fs.default.name</name> <value>hdfs://evotion00:54310</value> </property>
the hdfs_site.xml
<property> <name>dfs.replication</name> <value>3</value> <description>Default block replication. The actual number of replications can be specified when the file is created. The default is used if replication is not specified in create time. </description> </property> <property> <name>dfs.name.dir</name> <value>file:/home/hduser/hadoop_store/hdfs/namenode</value> </property> <property> <name>dfs.data.dir</name> <value>file:/home/hduser/hadoop_store/hdfs/datanode</value> </property>
I tried, hadoop namenode -format and restart but not working.
Many thanks in advance.
Created 09-22-2017 08:04 PM
Hi @Bin Ye, Check NameNode logs and share any error/exception. Some common issues:
Created 09-22-2017 08:04 PM
Hi @Bin Ye, Check NameNode logs and share any error/exception. Some common issues:
Created 09-22-2017 08:32 PM
Hi, @Ajay
When i format the namenode, it print out:
17/09/22 21:54:03 ERROR namenode.NameNode: Failed to start namenode. java.io.IOException: Cannot create directory /hadoop/hdfs/namenode/current
In fact the hdfs_site.xml file is configred to store data in file:/home/hduser/hadoop_store/hdfs/namenode.
I don't understand how could this happen. This is a completely different location
Do you any reasons, why is this happening?
Many Thanks in advance.
Bin Ye
Created 09-25-2017 10:57 PM
Hi @Bin Ye
Check for entry of "dfs.namenode.name.dir" in config files. Try to grep /hadoop/hdfs/namenode/current in config dir and see if you can locate the config file which is over-riding your settings.
Created 09-26-2017 02:30 AM
Hi @Bin Ye
You should change this property to fit your setting
<property>
<name>dfs.namenode.name.dir</name>
<value>/hadoop/hdfs/namenode</value>
</property>
Created 09-27-2017 12:40 PM
Many thanks, for your reply. I found the errors. I have two versions of hadoop installed and the config folder is symlink to other place.