Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 05-19-2016 05:40 PM
Please help me out,
Unable to figure out what the problem is while starting regionserver, It exits with following message
starting regionserver, logging to /var/log/hbase/hbase-root-regionserver-ip-172-31-19-88.out Java HotSpot(TM) 64-Bit Server VM warning: INFO: os::commit_memory(0x0000000300000000, 20401094656, 0) failed; error='Cannot allocate memory' (errno=12) # # There is insufficient memory for the Java Runtime Environment to continue. # Native memory allocation (mmap) failed to map 20401094656 bytes for committing reserved memory. # An error report file with more information is saved as: # /var/log/hbase/hs_err_pid31016.log
below are the free -m o/p:
total |used |free|shared|buffers|cached Mem: 68555 |21134 |47420|0|181 |14850 -/+ buffers/cache: 6102 62452 Swap: 0 0 0
I am not not sure if it is a Java Error or OS error
Below is are system configs:
Ram : 70gb os: Redhat centos 6.7 Ambari : 2.2.2 HDP : 2.4.2 Java Version (Ambari): 1.8.0_40
Created 06-13-2016 02:43 PM
Here is the solution
Hawq installation have caused a change to /etc/sysctl.conf
Had to change it back to default value and got rid of all the OOM errors.
vm.overcommit_memory=2Had to change to default value vm.overcommit_memory=0
Created 05-20-2016 06:58 PM
Thank you for the response,
Tried that one but seem to have no impact
Created 06-13-2016 02:43 PM
Here is the solution
Hawq installation have caused a change to /etc/sysctl.conf
Had to change it back to default value and got rid of all the OOM errors.
vm.overcommit_memory=2Had to change to default value vm.overcommit_memory=0