Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-10-2018 11:49 AM
Hi Folks,
I am using HDP 2.6.4 version, where i have installed hbase active and standby server with three region server.
I have started both on after another and both started successfully but both node automatically shutting down in some down while our HDFS is fully healthy. Following are the logs from hbase:
2018-12-10 10:17:20,767 INFO [LruBlockCacheStatsExecutor] hfile.LruBlockCache: totalSize=417.42 KB, freeSize=395.89 MB, m ax=396.30 MB, blockCount=0, accesses=0, hits=0, hitRatio=0, cachingAccesses=0, cachingHits=0, cachingHitsRatio=0,evictions =209, evicted=0, evictedPerRun=0.0 2018-12-10 10:18:48,539 INFO [Init Namespace Manager and Quota Manager Async] master.TableNamespaceManager: Waiting for n amespace table to be online. Time waited = 2100006 ms. 2018-12-10 10:22:20,767 INFO [LruBlockCacheStatsExecutor] hfile.LruBlockCache: totalSize=417.42 KB, freeSize=395.89 MB, m ax=396.30 MB, blockCount=0, accesses=0, hits=0, hitRatio=0, cachingAccesses=0, cachingHits=0, cachingHitsRatio=0,evictions =239, evicted=0, evictedPerRun=0.0 2018-12-10 10:23:48,538 ERROR [Init Namespace Manager and Quota Manager Async] master.HMaster: Namespace manager failed to start. java.io.IOException: Timedout 2400000ms waiting for namespace table to be assigned at org.apache.hadoop.hbase.master.TableNamespaceManager.start(TableNamespaceManager.java:109) at org.apache.hadoop.hbase.master.HMaster$1.run(HMaster.java:1162) at java.lang.Thread.run(Thread.java:745) 2018-12-10 10:23:48,539 FATAL [Init Namespace Manager and Quota Manager Async] master.HMaster: Master server abort: loaded coprocessors are: [] 2018-12-10 10:23:48,539 FATAL [Init Namespace Manager and Quota Manager Async] master.HMaster: Shutdown Master due to name space manager failed to start. java.io.IOException: Timedout 2400000ms waiting for namespace table to be assigned at org.apache.hadoop.hbase.master.TableNamespaceManager.start(TableNamespaceManager.java:109) at org.apache.hadoop.hbase.master.HMaster$1.run(HMaster.java:1162) at java.lang.Thread.run(Thread.java:745) 2018-12-10 10:23:48,539 INFO [Init Namespace Manager and Quota Manager Async] regionserver.HRegionServer: STOPPED: Shutdo wn Master due to namespace manager failed to start.
Created 12-10-2018 01:03 PM
Hi @Vinay,
It's seems to be an issue with stale WAL splits, try removing WAL's from below hdfs location and restart the Hbase and region services.
/apps/hbase/data/WALs/
Please note that, removing them is almost never an ideal situation unless there is no data in HBase.
Created 12-10-2018 01:03 PM
Hi @Vinay,
It's seems to be an issue with stale WAL splits, try removing WAL's from below hdfs location and restart the Hbase and region services.
/apps/hbase/data/WALs/
Please note that, removing them is almost never an ideal situation unless there is no data in HBase.
Created 12-12-2018 10:45 AM