Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-07-2016 10:03 AM
Hello,
I tried to connect to hive using jdbc but i had the following error:
Error: Could not open client transport with JDBC Uri: jdbc:hive2://server:10000/;principal=<Server_Principal_of_HiveServer2> java.net.ConnectException: Connection refused (state=08S01,code=0)
I got the same error from beeline : beeline -u 'jdbc:hive2://server:10000/;principal=<Server_Principal_of_HiveServer2>'
I will be thankfull for your help.
thanks
Hive version: 1.2.1
HDP: 2.3
Created 01-07-2016 07:21 PM
is your hive Server is running in HTTP mode?
Connection URL When HiveServer2 Is Running in HTTP Mode:-
jdbc:hive2://<host>:<port>/<db>;transportMode=http;httpPath=<http_endpoint>
where:-
<http_endpoint> is the corresponding HTTP endpoint configured in hive-site.xml. Default value is cliservice.
Default port for HTTP transport mode is 10001.
Created 11-14-2016 03:55 AM
This happened to me. What I did was connect run the command below from beeline:
beeline> !connect jdbc:hive2://
Then, will ask for my user and pass, and i'm connected to my hive.
I'm having issues now connecting to hiveserver from Hue and Ambari View thou. 😞
EDIT:
I have 2 hiveserver2, hive metastore and webhcat servers.
Created 02-15-2022 07:56 AM
There is kerboras keytab issue, please take new ticket and connect with HS2, it will work.
Created 01-19-2017 11:23 PM
Hi All,
HiveServer2 is constantly going down and it works max for a day when we restart. The following is the error from hiveserver2 log when it is down.
Connection failed on host ip-172-30-5-146.us-west-2.compute.internal:10000 (Traceback (most recent call last): File "/var/lib/ambari-agent/cache/common-services/HIVE/0.12.0.2.0/package/alerts/alert_hive_thrift_port.py", line 200, in execute check_command_timeout=int(check_command_timeout)) File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/hive_check.py", line 74, in check_thrift_port_sasl timeout=check_command_timeout) File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 154, in __init__ self.env.run() File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run self.run_action(resource, action) File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action provider_action() File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 238, in action_run tries=self.resource.tries, try_sleep=self.resource.try_sleep) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70, in inner result = function(command, **kwargs) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 92, in checked_call tries=tries, try_sleep=try_sleep) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 140, in _call_wrapper result = _call(command, **kwargs_copy) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call raise Fail(err_msg) Fail: Execution of '! beeline -u 'jdbc:hive2://ip-172-30-5-146.us-west-2.compute.internal:10000/;transportMode=binary' -e '' 2>&1| awk '{print}'|grep -i -e 'Connection refused' -e 'Invalid URL'' returned 1. Error: Could not open client transport with JDBC Uri: jdbc:hive2://ip-172-30-5-146.us-west-2.compute.internal:10000/;transportMode=binary: java.net.ConnectException: Connection refused (state=08S01,code=0) Error: Could not open client transport with JDBC Uri: jdbc:hive2://ip-172-30-5-146.us-west-2.compute.internal:10000/;transportMode=binary: java.net.ConnectException: Connection refused (state=08S01,code=0)
Created 07-12-2017 10:37 PM
I ran into similar problem as @Hari Krishnan Umapathy, my HiveServer2 was going down as soon as I started it. I recommend following steps to debug the:
- Check the error logs(.err) under - /var/log/hive
- Restart the service and put a tail on the new logs: tail -f hiverserver2.log
Note: I was running into out of memory error on my node and stopped some of the unwanted services and was able to bring up hive and beeline.
Created 11-06-2024 12:29 AM
Hi,
I am trying to connect hive database from nodejs using hive-driver npm. In that code,the session cannot be established to access the hive database.
I am putting the console for each and every variables,but the log was printed,before the session establishing code only.please anyone help me on this.please refer a snap shot below.