Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-24-2016 09:48 AM
The documentation says it should have CentOS 5.0 or 6.0.
I also reffered https://community.hortonworks.com/questions/2210/libsasl-version-fro-hive-obdc-rhel-7.html.
I have 3 node cluster of HDP 2.3. o CentOS 7 when I try installing I get the following output:
[root@node1 enggusr]# yum --nogpgcheck localinstall hive-odbc-native-2.0.5.1005-1.el6.x86_64.rpm
Loaded plugins: fastestmirror, priorities
Examining hive-odbc-native-2.0.5.1005-1.el6.x86_64.rpm: hive-odbc-native-2.0.5.1005-1.x86_64
Marking hive-odbc-native-2.0.5.1005-1.el6.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package hive-odbc-native.x86_64 0:2.0.5.1005-1 will be installed
--> Processing Dependency: cyrus-sasl-gssapi(x86-64) >= 2.1.22 for package: hive-odbc-native-2.0.5.1005-1.x86_64
HDP-2.3 | 2.9 kB 00:00
HDP-UTILS-1.1.0.20 | 2.9 kB 00:00
Updates-ambari-2.2.0.0 | 2.9 kB 00:00
base | 3.6 kB 00:00
extras | 3.4 kB 00:00
mysql-connectors-community | 2.5 kB 00:00
mysql-tools-community | 2.5 kB 00:00
mysql56-community | 2.5 kB 00:00
updates | 3.4 kB 00:00
Loading mirror speeds from cached hostfile
* base: ftp.iitm.ac.in
* extras: ftp.iitm.ac.in
* updates: ftp.iitm.ac.in
--> Processing Dependency: cyrus-sasl-plain(x86-64) >= 2.1.22 for package: hive-odbc-native-2.0.5.1005-1.x86_64
--> Processing Dependency: libsasl2.so.2()(64bit) for package: hive-odbc-native-2.0.5.1005-1.x86_64
--> Running transaction check
---> Package cyrus-sasl-gssapi.x86_64 0:2.1.26-20.el7_2 will be installed
---> Package cyrus-sasl-plain.x86_64 0:2.1.26-20.el7_2 will be installed
---> Package hive-odbc-native.x86_64 0:2.0.5.1005-1 will be installed
--> Processing Dependency: libsasl2.so.2()(64bit) for package: hive-odbc-native-2.0.5.1005-1.x86_64
--> Finished Dependency Resolution
Error: Package: hive-odbc-native-2.0.5.1005-1.x86_64 (/hive-odbc-native-2.0.5.1005-1.el6.x86_64)
Requires: libsasl2.so.2()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Created 02-24-2016 10:57 AM
You have to resolve the dependencies.
Issue: You are using centos6 driver in centos7
[centos@nsnode1 ~]$ wget http://public-repo-1.hortonworks.com/HDP/hive-odbc/2.0.5.1005/centos6/hive-odbc-native-2.0.5.1005-1....
--2016-02-24 10:55:41-- http://public-repo-1.hortonworks.com/HDP/hive-odbc/2.0.5.1005/centos6/hive-odbc-native-2.0.5.1005-1....
Resolving public-repo-1.hortonworks.com (public-repo-1.hortonworks.com)... 54.230.141.82, 54.230.141.109, 54.230.141.150, ...
Connecting to public-repo-1.hortonworks.com (public-repo-1.hortonworks.com)|54.230.141.82|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 17057810 (16M) [application/x-rpm]
Saving to: ‘hive-odbc-native-2.0.5.1005-1.el6.x86_64.rpm’
100%[===========================================================================================================================================================>] 17,057,810 1.62MB/s in 11s
2016-02-24 10:55:52 (1.44 MB/s) - ‘hive-odbc-native-2.0.5.1005-1.el6.x86_64.rpm’ saved [17057810/17057810]
[centos@nsnode1 ~]$ rpm -i hive-odbc-native-2.0.5.1005-1.el6.x86_64.rpm
error: Failed dependencies:
cyrus-sasl-gssapi(x86-64) >= 2.1.22 is needed by hive-odbc-native-2.0.5.1005-1.x86_64
cyrus-sasl-plain(x86-64) >= 2.1.22 is needed by hive-odbc-native-2.0.5.1005-1.x86_64
libsasl2.so.2()(64bit) is needed by hive-odbc-native-2.0.5.1005-1.x86_64
[centos@nsnode1 ~]$
Created 02-24-2016 10:04 AM
yum not working - could not find libsasl2.so.2 The upgrade process resulted in me having /usr/lib64/libsasl2.so.3 . just create a symlink in /usr/lib64 named libsasl2.so.2 pointing to /usr/lib64/libsasl2.so.3 via:ln -s /usr/lib64/libsasl2.so.3 /usr/lib64/libsasl2.so.2
Created 02-24-2016 10:26 AM
Yes I have created a symlink, but after creating a symlink, I still get the same error while installing the driver
Created 02-24-2016 10:48 AM
You could try with -skip-broken, if yum requires the package but its not available in CentOS7 anymore. Your simlink might mean it actual works in reality and -skip-broken would tell yum that all is well.
Just theory though.
Created 02-24-2016 10:57 AM
You have to resolve the dependencies.
Issue: You are using centos6 driver in centos7
[centos@nsnode1 ~]$ wget http://public-repo-1.hortonworks.com/HDP/hive-odbc/2.0.5.1005/centos6/hive-odbc-native-2.0.5.1005-1....
--2016-02-24 10:55:41-- http://public-repo-1.hortonworks.com/HDP/hive-odbc/2.0.5.1005/centos6/hive-odbc-native-2.0.5.1005-1....
Resolving public-repo-1.hortonworks.com (public-repo-1.hortonworks.com)... 54.230.141.82, 54.230.141.109, 54.230.141.150, ...
Connecting to public-repo-1.hortonworks.com (public-repo-1.hortonworks.com)|54.230.141.82|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 17057810 (16M) [application/x-rpm]
Saving to: ‘hive-odbc-native-2.0.5.1005-1.el6.x86_64.rpm’
100%[===========================================================================================================================================================>] 17,057,810 1.62MB/s in 11s
2016-02-24 10:55:52 (1.44 MB/s) - ‘hive-odbc-native-2.0.5.1005-1.el6.x86_64.rpm’ saved [17057810/17057810]
[centos@nsnode1 ~]$ rpm -i hive-odbc-native-2.0.5.1005-1.el6.x86_64.rpm
error: Failed dependencies:
cyrus-sasl-gssapi(x86-64) >= 2.1.22 is needed by hive-odbc-native-2.0.5.1005-1.x86_64
cyrus-sasl-plain(x86-64) >= 2.1.22 is needed by hive-odbc-native-2.0.5.1005-1.x86_64
libsasl2.so.2()(64bit) is needed by hive-odbc-native-2.0.5.1005-1.x86_64
[centos@nsnode1 ~]$
Created 02-24-2016 11:10 AM
@Kunal Gaikwad @Benjamin Leonhardi
symlink does not work
[root@nsnode1 lib64]# ls -l libsasl2.so.*
lrwxrwxrwx. 1 root root 24 Feb 24 11:03 libsasl2.so.2 -> /usr/lib64/libsasl2.so.3
lrwxrwxrwx. 1 root root 17 Feb 24 10:57 libsasl2.so.3 -> libsasl2.so.3.0.0
-rwxr-xr-x. 1 root root 121296 Feb 16 16:10 libsasl2.so.3.0.0
[root@nsnode1 lib64]# ln -s /usr/lib64/libsasl2.so.3
libsasl2.so.3 libsasl2.so.3.0.0
[root@nsnode1 lib64]# ln -s /usr/lib64/libsasl2.so.3
libsasl2.so.3 libsasl2.so.3.0.0
[root@nsnode1 lib64]# ln -s /usr/lib64/libsasl2.so.3.0.0 /usr/lib64/libsasl2.so.2
ln: failed to create symbolic link ‘/usr/lib64/libsasl2.so.2’: File exists
[root@nsnode1 lib64]# rm /usr/lib64/libsasl2.so.2
rm: remove symbolic link ‘/usr/lib64/libsasl2.so.2’? yes
[root@nsnode1 lib64]# ln -s /usr/lib64/libsasl2.so.3.0.0 /usr/lib64/libsasl2.so.2
[root@nsnode1 lib64]# cd
[root@nsnode1 ~]# rpm -i hive-odbc-native-2.0.5.1005-1.el6.x86_64.rpm
error: Failed dependencies:
libsasl2.so.2()(64bit) is needed by hive-odbc-native-2.0.5.1005-1.x86_64
[root@nsnode1 ~]#
Created 02-24-2016 11:11 AM
@Kunal Gaikwad I suggest to wait for the final release of driver for centos7
Created 02-24-2016 11:15 AM
Install it with skipped dependencies as a workaround? If the symlink is created he might just work
But I agree safer to wait.
Created 02-25-2016 09:08 AM
I guess! ill wait for the driver release
Created 02-25-2016 09:18 AM
@Kunal Gaikwad Makes sense!! Please hit accept on the best answer to close the thread