Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 11-14-2016 06:49 AM
Hi!
I'm trying to crate new instance for my hive view, but I couldn't see where the "Create Instance" anywhere on Ambari>Views as stated here in guide below;
Please help.
Created 11-15-2016 03:42 AM
There are multiple errors in your logs:
1. Below error indicates that it is not able to locate "/etc/krb5.conf" file. Or may be it is not readable because of incorrect file permission issues.
Caused by: KrbException: Cannot locate default realm at sun.security.krb5.Config.getDefaultRealm(Config.java:1029) ... 93 more
2. Looks like the view is not created properly. YOu shoudl recreate the view using "local cluster" option.
15 Nov 2016 09:02:23,706 WARN [qtp-ambari-client-6023] ViewRegistry:855 - Could not find the cluster identified by OLDclusterNAME.
3. Following error also indicates that you have kerberos installed, but it is not properly installed. See below "KerberosUtil.getDefaultRealm"
15 Nov 2016 09:02:23,707 ERROR [qtp-ambari-client-6023] ViewContextImpl:241 - Failed to get username java.lang.reflect.InvocationTargetException at sun.reflect.GeneratedMethodAccessor617.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at org.apache.hadoop.security.authentication.util.KerberosUtil.getDefaultRealm(KerberosUtil.java:84) at org.apache.ambari.server.view.ViewContextImpl.getUsername(ViewContextImpl.java:233) at org.apache.ambari.view.hive.utils.SharedObjectsFactory.getTagName(SharedObjectsFactory.java:145)
If you are using kerberos then you should setup the "WebHDFS Authentication" and "Hive Authentication" attribute of your HiveView with the principal defined in it as described in the following link:
Created 11-14-2016 06:51 AM
Are you getting any error in the "/var/log/ambari-server/ambari-server.log" ?
Is it kerberized error?
Created 11-15-2016 01:06 AM
Hi @jss
1. Yes I'm getting errors. See below;
Caused by: KrbException: Cannot locate default realm at sun.security.krb5.Config.getDefaultRealm(Config.java:1029) ... 93 more 15 Nov 2016 09:02:23,706 WARN [qtp-ambari-client-6023] ViewRegistry:855 - Could not find the cluster identified by OLDclusterNAME. 15 Nov 2016 09:02:23,707 ERROR [qtp-ambari-client-6023] ViewContextImpl:241 - Failed to get username java.lang.reflect.InvocationTargetException at sun.reflect.GeneratedMethodAccessor617.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at org.apache.hadoop.security.authentication.util.KerberosUtil.getDefaultRealm(KerberosUtil.java:84) at org.apache.ambari.server.view.ViewContextImpl.getUsername(ViewContextImpl.java:233) at org.apache.ambari.view.hive.utils.SharedObjectsFactory.getTagName(SharedObjectsFactory.java:145)
2. I'm not in kerberized mode. :? But I have ranger on my cluster.
Created 11-15-2016 03:42 AM
There are multiple errors in your logs:
1. Below error indicates that it is not able to locate "/etc/krb5.conf" file. Or may be it is not readable because of incorrect file permission issues.
Caused by: KrbException: Cannot locate default realm at sun.security.krb5.Config.getDefaultRealm(Config.java:1029) ... 93 more
2. Looks like the view is not created properly. YOu shoudl recreate the view using "local cluster" option.
15 Nov 2016 09:02:23,706 WARN [qtp-ambari-client-6023] ViewRegistry:855 - Could not find the cluster identified by OLDclusterNAME.
3. Following error also indicates that you have kerberos installed, but it is not properly installed. See below "KerberosUtil.getDefaultRealm"
15 Nov 2016 09:02:23,707 ERROR [qtp-ambari-client-6023] ViewContextImpl:241 - Failed to get username java.lang.reflect.InvocationTargetException at sun.reflect.GeneratedMethodAccessor617.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at org.apache.hadoop.security.authentication.util.KerberosUtil.getDefaultRealm(KerberosUtil.java:84) at org.apache.ambari.server.view.ViewContextImpl.getUsername(ViewContextImpl.java:233) at org.apache.ambari.view.hive.utils.SharedObjectsFactory.getTagName(SharedObjectsFactory.java:145)
If you are using kerberos then you should setup the "WebHDFS Authentication" and "Hive Authentication" attribute of your HiveView with the principal defined in it as described in the following link:
Created 11-16-2016 03:29 AM
WOW. Thank you for laying it out for me. For #2, how can I recreate the view? Do I need to resolve issue #1 and #3 first? 🙂