Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-30-2016 12:39 PM
Hi,
I have just completed an upgrade of HDP from 2.3.2 to 2.4.2. The Ambari Hive view throws error when accessed. The following is the error reported. Can someone please help on this.
Failed on local exception: com.google.protobuf.InvalidProtocolBufferException: Protocol message end-group tag did not match expected tag.; Host Details : local host is: "ambari-machine.com/10.x.y.109"; destination host is: "namenode.com":50070;
Created 06-30-2016 12:56 PM
Can you crosscheck the HIVE view configuration - for namenode specific hostname -
"fs.defaultFS"
Try to create a new view for hive and check if that works
Created 06-30-2016 12:56 PM
Can you crosscheck the HIVE view configuration - for namenode specific hostname -
"fs.defaultFS"
Try to create a new view for hive and check if that works
Created 06-30-2016 01:05 PM
Thanks Sagar. I updated "fs.defaultFS" as it was missing the port number after the upgrade. I then restarted ambari, it worked fine. Appreciate your help.
Created 06-30-2016 07:43 PM
Is Namenode HA enabled in the cluster? If so, the fs.defaultFS property defined in Ambari Hive view should not include the port number.
Created 07-01-2016 09:51 AM
@vpoornalingam - I get it now. Namenode HA was enabled temporarily and I disabled it later. Thanks it was the cause.