Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-18-2016 04:26 PM
Using HDP 2.3.2 sandbox.
I have an external table defined over a folder that contains XML documents. There is 1 column in this table with the column containing each documents data as a string.
I am trying to create a view on top of the XML data with xpaths. So for example,
CREATE VIEW myview (column1,...Column N) AS SELECT xpath_string(rawxml, '/my/xpath/to/value'), xpath_string(rawxml, '/another/xpath') FROM myxmltable;
The XML document has 400+ xpaths that I want to grab and put into the view. I can do about 60 columns worth of xpaths before I get this error.
FAILED: Hive Internal Error: com.sun.jersey.api.client.ClientHandlerException(java.io.IOException: org.apache.hadoop.security.authentication.client.AuthenticationException: Authentication failed, status: 413, message: FULL head)
com.sun.jersey.api.client.ClientHandlerException: java.io.IOException: org.apache.hadoop.security.authentication.client.AuthenticationException: Authentication failed, status: 413, message: FULL head
UPDATE:
I disabled authentication in Ambari, restarted and changed http to binary.
So I removed authentication temporarily to confirm that was causing the issue. After doing so, I am now getting a completely different error message.
FAILED: Hive Internal Error: com.sun.jersey.api.client.ClientHandlerException(java.io.IOException: java.io.IOException: Error writing to server) com.sun.jersey.api.client.ClientHandlerException: java.io.IOException: java.io.IOException: Error writing to server at com.sun.jersey.client.urlconnection.URLConnectionClientHandler.handle(URLConnectionClientHandler.java:149)
Created 02-18-2016 04:34 PM
Ok might have solved my own issue. This looks to be a problem with the http request/response header size. This defect is here and was fixed in 1.3.0 and 2.0.0. Other than upgrading Hive is there anyway I can set these values?
Created 02-18-2016 04:34 PM
Ok might have solved my own issue. This looks to be a problem with the http request/response header size. This defect is here and was fixed in 1.3.0 and 2.0.0. Other than upgrading Hive is there anyway I can set these values?
Created 02-18-2016 05:33 PM
Nice! I am guessing that you fixed it.
Created 02-18-2016 05:45 PM
Actually slightly different issue now though. some other error.