Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Hive queries are failing in Ineractive quey HDInsight 3.6

avatar
Super Collaborator

Hello Team,

we had recently enabled https for azure storage and changed fs.defaultFS parameter in core-site.xml. we are able to access the hdfs file system . Now our hive queries are failing with the below error ? Error: java.io.IOException: org.apache.hadoop.fs.azure.AzureException: com.microsoft.azure.storage.StorageException: The account being accessed does not support http. (state=,code=0) we have changed the parameter for hive.aux.jars.path to use wasbs. still we are facing the same issue ? do we missed anything in hive-site.xml to reach wasbs ? Any help to overcome this issue much appreciated Thanks in advance!

1 ACCEPTED SOLUTION

avatar
Expert Contributor

You might look at the table definition (show create table x) and verify the prefix on the table location. Hive stores the whole filespec including the protocol.

View solution in original post

1 REPLY 1

avatar
Expert Contributor

You might look at the table definition (show create table x) and verify the prefix on the table location. Hive stores the whole filespec including the protocol.