Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

HiveServer2 OnOutOfMemoryError

avatar
Explorer

Hi,

After running hive job and take a look at ps -ef | grep hive, I see messages for hiveserver2 and hivemetastore like that:

 

...-Xms1073741824 -Xmx1073741824 -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:-CMSConcurrentMTEnabled -XX:CMSInitiatingOccupancyFraction=70 -XX:+CMSParallelRemarkEnabled -XX:OnOutOfMemoryError=/usr/lib64/cmf/service/common/killparent.sh...

Does it means, that where is not enough memory allocated for  hiveserver2 and hivemetastore java heap size parameters?

 

 

 

1 ACCEPTED SOLUTION

avatar
Contributor
This just means, in the case of running out of memory, execute this script.
It doesn't mean there is not enough memory.

View solution in original post

2 REPLIES 2

avatar
Contributor
This just means, in the case of running out of memory, execute this script.
It doesn't mean there is not enough memory.

avatar
Explorer

Understood. Thanks.