Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 10-09-2018 05:20 AM
Hi,
I installed HiveServer2 on ambari 2.6. Whlie accessing hive through terminal or webUI, its not working. The error is comming Error: Could not open client transport with JDBC Url: jdbc:hive2://ip:10000/transportMode=binary:Java.net.ConnectionException (Connection Refused).
SET hive.exec.dynamic.partition = true;
SET hive.exec.dynamic.partition.mode = nonstrict;
SET hive.exec.max.dynamic.partitions = 10000;
SET hive.exec.max.dynamic.partitions.pernode = 1000;
these are the configuration which is available on config file.
Could anybody help regarding this issue would be great.
Thanks.
Created 10-09-2018 07:19 AM
Looks like a Tuning issue. Here we see that the "Requested Memory" is More than the "Max Memory".
requestedMemory=10096, maxMemory=7936.
.
Please refer to the following Support KB to know more about this kind of error:
https://community.hortonworks.com/content/supportkb/48814/resource-manager-unable-to-start.html
Created 10-09-2018 05:25 AM
Are you able to do Telnet on the HS2 Hostname & Port?
From Hive Client host
# telnet $HS2_HOSTNAME 10000 (OR) # nc -v $HS2_HOSTNAME 10000
.
On the HS2 host can you please check if the port 10000 is listening and bound properly and the IP tables is disabled?
# netstat -tnlpa | grep 10000 # service iptables stop
.
Also please restart HS2 and then see if you find any Errors in the HS2 log?
# ls -l /var/log/hive/hiveserver2.log
.
Also can you please try with the Zookeeper based dynamic URLs? Like following to see if it works?
# beeline -n barney -p bedrock -u "jdbc:hive2://m1.hdp.local:2181,m2.hdp.local:2181,m3.hdp.local:2181/<db>"
https://community.hortonworks.com/articles/4103/hiveserver2-jdbc-connection-url-examples.html
Created 10-09-2018 07:06 AM
Thanks for your quick reply.
I tried telnet $HS 10000 and nc -v $HS 10000, but nothing is coming.
When i run the command "nc -v $HS Host 10000", i got only this Ncat: Version 7.50 ( https://nmap.org/ncat )
Ncat: Connection refused.
Then tried
netstat -tnlpa | grep 10000 but nothing is coming.
When i run i got below error
ls -l /var/log/hive/hiveserver2.log
Caused by: org.apache.hadoop.yarn.exceptions.InvalidResourceRequestException: Invalid resource request, requested memory < 0, or requested memory > max configured, requestedMemory=10096, maxMemory=7936.
Could you pls let me know more about it.
Created 10-09-2018 07:19 AM
Looks like a Tuning issue. Here we see that the "Requested Memory" is More than the "Max Memory".
requestedMemory=10096, maxMemory=7936.
.
Please refer to the following Support KB to know more about this kind of error:
https://community.hortonworks.com/content/supportkb/48814/resource-manager-unable-to-start.html
Created 10-09-2018 07:26 AM
Its working fine now . Thank you @Jay Kumar SenSharma