Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Host Monitor and Service Monitor is not starting after kerberos

avatar
Expert Contributor

I have sucessfully installed Kerberos and integrated with Cloudera Mnagaer, while starting the cloudera manager services i'm getting below error for Host Monitor and Service Monitor

 

Host Monitor error log

Jan 9, 5:24:56.202 PM 	ERROR 	com.cloudera.cmon.firehose.Main 	

Error creating LevelDB timeseries store in directory /var/lib/cloudera-host-monitor/ts
org.fusesource.leveldbjni.internal.NativeDB$DBException: Invalid argument: /var/lib/cloudera-host-monitor/ts/ts_entity_metadata: does not exist (create_if_missing is false)
	at org.fusesource.leveldbjni.internal.NativeDB.checkStatus(NativeDB.java:194)
	at org.fusesource.leveldbjni.internal.NativeDB.open(NativeDB.java:212)
	at org.fusesource.leveldbjni.JniDBFactory.open(JniDBFactory.java:168)
	at com.cloudera.cmon.tstore.leveldb.LDBUtils.openVersionedDB(LDBUtils.java:246)
	at com.cloudera.cmon.tstore.leveldb.LDBTimeSeriesMetadataStore.openMetadataDB(LDBTimeSeriesMetadataStore.java:149)
	at com.cloudera.cmon.tstore.leveldb.LDBTimeSeriesMetadataStore.<init>(LDBTimeSeriesMetadataStore.java:139)
	at com.cloudera.cmon.firehose.Main.main(Main.java:450)

Service Monitor error log

Jan 9, 5:24:56.475 PM 	ERROR 	com.cloudera.cmon.firehose.Main 	

Error creating LevelDB timeseries store in directory /var/lib/cloudera-service-monitor/ts
org.fusesource.leveldbjni.internal.NativeDB$DBException: Invalid argument: /var/lib/cloudera-service-monitor/ts/ts_entity_metadata: does not exist (create_if_missing is false)
	at org.fusesource.leveldbjni.internal.NativeDB.checkStatus(NativeDB.java:194)
	at org.fusesource.leveldbjni.internal.NativeDB.open(NativeDB.java:212)
	at org.fusesource.leveldbjni.JniDBFactory.open(JniDBFactory.java:168)
	at com.cloudera.cmon.tstore.leveldb.LDBUtils.openVersionedDB(LDBUtils.java:246)
	at com.cloudera.cmon.tstore.leveldb.LDBTimeSeriesMetadataStore.openMetadataDB(LDBTimeSeriesMetadataStore.java:149)
	at com.cloudera.cmon.tstore.leveldb.LDBTimeSeriesMetadataStore.<init>(LDBTimeSeriesMetadataStore.java:139)
	at com.cloudera.cmon.firehose.Main.main(Main.java:450)

What is the issue

1 ACCEPTED SOLUTION

avatar
Expert Contributor
I fixed the issue, by doing below

Seems Level Database DB is corrupted, and did below

mv /var/lib/cloudera-service-monitor /var/lib/cloudera-service-monitor.moved

mv /var/lib/cloudera-host-monitor /var/lib/cloudera-host-monitor.moved

Then restarted the services again, it worked

View solution in original post

1 REPLY 1

avatar
Expert Contributor
I fixed the issue, by doing below

Seems Level Database DB is corrupted, and did below

mv /var/lib/cloudera-service-monitor /var/lib/cloudera-service-monitor.moved

mv /var/lib/cloudera-host-monitor /var/lib/cloudera-host-monitor.moved

Then restarted the services again, it worked