Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-04-2018 03:33 PM
I received the following error using date functions in Hive. How are are permissions granted on dummy database/dummy table?
0:
jdbc:hive2://xxx:xxx,> SELECT DATE_ADD('2017-12-21', 1);
Error:
Error while compiling statement: FAILED: HiveAccessControlException Permission denied: user [xxx] does
not have [SELECT] privilege on [_dummy_database/_dummy_table]
(state=42000,code=40000)
Created 01-06-2018 05:42 AM
You can grant workaround by creating Ranger policy on _dummy_database. Ranger doesn't really check the database, just grant full access on _dummy_database to all. Guess you are hitting the same HIVE-11498 bug which I have already experienced.
Hope this helps you.
Created 01-06-2018 05:42 AM
You can grant workaround by creating Ranger policy on _dummy_database. Ranger doesn't really check the database, just grant full access on _dummy_database to all. Guess you are hitting the same HIVE-11498 bug which I have already experienced.
Hope this helps you.
Created 01-10-2018 09:06 PM
This worked for us. Thank you, @Sridhar Reddy.