Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

How to solve ambari-agent start failed: No handlers could be found for logger "ambari_agent.AmbariConfig"

avatar
New Member

ERROR: ambari-agent start failed. For more details, see /var/log/ambari-agent/ambari-agent.out: ==================== No handlers could be found for logger "ambari_agent.AmbariConfig"

No handlers could be found for logger "ambari_agent.AmbariConfig"

Ambari prefix dir %s not configured, can't continue

1 ACCEPTED SOLUTION

avatar
Master Mentor

@Hema Penumatsa

Can you try to reinstall it on the node that's causing a problem,you will first need to stop the agent, then run the below commands.

# yum install epel-release
# yum erase ambari-agent
# yum install -y ambari-agent

Then edit the ambari-agent.ini, and under the Server change the host to your Ambari server FQDN

vi /etc/ambari-agent/conf/ambari-agent.ini

[server]
hostname={your.ambari.server.hostname}

Then start the agent.

This should resolve the problem

View solution in original post

4 REPLIES 4

avatar
Master Mentor

@Hema Penumatsa

Please check if you have the following file present ?

/usr/lib/python2.6/site-packages/ambari_agent/AmbariConfig.py

.

Also if you have performed any ambari agent/server upgrade then chances are very high that these files might not be upgraded properly. If you still find any issue then try reinstalling ambari agent.

avatar
New Member

Solved after reinstalling ambari agent. Thanks !

avatar
Master Mentor

@Hema Penumatsa

Can you try to reinstall it on the node that's causing a problem,you will first need to stop the agent, then run the below commands.

# yum install epel-release
# yum erase ambari-agent
# yum install -y ambari-agent

Then edit the ambari-agent.ini, and under the Server change the host to your Ambari server FQDN

vi /etc/ambari-agent/conf/ambari-agent.ini

[server]
hostname={your.ambari.server.hostname}

Then start the agent.

This should resolve the problem

avatar
New Member

This worked. Thanks !