Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 04-15-2016 04:16 PM
Created 04-15-2016 04:25 PM
If you haven't already installed Nifi on the cluster, to update the Nifi service definition in Ambari on HDP 2.4 sandbox, you can follow the steps here
rm -rf /var/lib/ambari-server/resources/stacks/HDP/2.4/services/NIFI sudo git clone https://github.com/abajwa-hw/ambari-nifi-service.git /var/lib/ambari-server/resources/stacks/HDP/2.4/services/NIFI service ambari restart
Then restart Ambari and install Nidi using 'Add service wizard' as usual
Created 04-15-2016 08:28 PM
If the curl request errors out with the 500 error run the below command (from same README) and then re-try the original curl request
#if above errors out, run below first to fully stop the service
curl -u admin:$PASSWORD -i -H 'X-Requested-By: ambari' -X PUT -d '{"RequestInfo": {"context" :"Stop $SERVICE via REST"}, "Body": {"ServiceInfo": {"state": "INSTALLED"}}}' http://$AMBARI_HOST:8080/api/v1/clusters/$CLUSTER/services/$SERVICE
Created 04-18-2016 01:29 PM
Thanks. it worked.
Created 10-11-2016 06:13 PM
After this, all service actions is disable. And i received this error 500 status code received on GET method for API: /api/v1/stacks/HDP/versions/2.4/recommendations
Created 10-31-2016 07:42 AM
I am facing the same issue. Did anyone have solution to resolve this issue!
I have Nifi old version service added in HDP 2.4. I followed the steps provided above
After doing the steps, I am seeing all the services showing heart beat lost with question mark icon status!
Created 10-31-2016 06:54 PM
I resolved this problem. I create a new VM hortonworks, and do not install nifi, after this, download the new version (https://www.apache.org/dyn/closer.lua?path=/nifi/1.0.0/nifi-1.0.0-bin.zip) and use sudo sh /opt/nifi-1.0.0/bin/nifi.sh start .The problem has been resolved and nifi update has concluded.