Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-19-2016 09:58 PM
I am able to connect to hive via beeline by issuing
>beeline
and then
>!connect jdbc:hive2://zzz.com:2181,zzzz.com:2181,zzz.com:2181/;serviceDiscoveryMode=zooKeeper;zooKeeperNamespace=hiveserver2
However I would like to connect to hive in 1 shot using -u
>beeline -u jdbc:hive2://zzz.com:2181,zzzz.com:2181,zzz.com:2181/;serviceDiscoveryMode=zooKeeper;zooKeeperNamespace=hiveserver2
and it fails
[LAKE] [smanjee@lake1 ~]# beeline -u jdbc:hive2://z:2181,zzzzz.com:2181,zzzzzz.com:2181/;serviceDiscoveryMode=zooKeeper;zooKeeperNamespace=hiveserver2 SLF4J: Class path contains multiple SLF4J bindings. SLF4J: Found binding in [jar:file:/usr/hdp/2.5.3.0-37/phoenix/phoenix-4.7.0.2.5.3.0-37-hive.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: Found binding in [jar:file:/usr/hdp/2.5.3.0-37/hadoop/lib/slf4j-log4j12-1.7.10.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation. SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory] Connecting to jdbc:hive2://zzzzz.com:2181,zzzzz.com:2181,zzzzz.com:2181/ 16/12/19 21:56:21 [main]: WARN jdbc.HiveConnection: Failed to connect to zzzzz.com:2181 Error: Could not open client transport with JDBC Uri: jdbc:hive2://zzzzz.com:2181/: null (state=08S01,code=0) Beeline version 1.2.1000.2.5.3.0-37 by Apache Hive 0: jdbc:hive2://zzzz.com:2 (closed)>
Created 12-20-2016 03:29 AM
HWX support found my issue. here is what I was doing wrong::: Forgot the double quotes around the jdbc driver
beeline -u "jdbc:hive2://example.com:2181,example.com:2181,example:2181/;serviceDiscoveryMode=zooKeeper;zooKeeperNamespace=hiveserver2"
and now it works. cool. @milind pandit thank you for your help. I am sure port checking should be on the list of what to check. however, the issue where was missing double quotes.
Created 12-19-2016 11:20 PM
@Sunile Manjee I am able to connect in one shot only after using the same host in the url from where I am running the beeline. e.g if I am running beeline from host z , I was able to connect using beeline -u jdbc:hive2://z:2181/;serviceDiscoveryMode=zooKeeper;zooKeeperNamespace=hiveserver2 I am thinking I might have to open the port 2181 explicitly for other host to access.
Created 12-19-2016 11:36 PM
Its working for me , I did the following. 1. Opend the port 2181 2. Stop the local firewall on all nodes. (iptables).
Created 12-20-2016 03:29 AM
HWX support found my issue. here is what I was doing wrong::: Forgot the double quotes around the jdbc driver
beeline -u "jdbc:hive2://example.com:2181,example.com:2181,example:2181/;serviceDiscoveryMode=zooKeeper;zooKeeperNamespace=hiveserver2"
and now it works. cool. @milind pandit thank you for your help. I am sure port checking should be on the list of what to check. however, the issue where was missing double quotes.