Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-20-2016 05:30 AM
Hi there,
I download sandbox HDP_2.3.2_virtualbox.ova for evaluating the TDE(transparent data encryption) feature. After simple setup, the HDFS CLI works as expected; but I also want to see TDE works with NFS.
As yo can see below, Both TDE and NFS works fine on their own. However, I can't make them to work together. In my tests, I created one encrypted /zone_encr dir and one unencrypted /zone_plain dir; I mounted the HDFS on /mnt/nfs.
Test 1: Unencrypted zone works fine.
copy file to/from /mnt/nfs/zone_plain/ works as epxected;
Test 2: Encrypted zone not working.
[hdfs@sandbox ~]$ cp test.txt /mnt/nfs/zone_encr/testx.txt cp: cannot create regular file `/mnt/nfs/zone_encr/testx.txt': Permission denied [hdfs@sandbox ~]$ cat /mnt/nfs/zone_encr/test2.txt cat: /mnt/nfs/zone_encr/test2.txt: Stale file handle
Test 3: Giving hdfs all the KMS managed permissions
After giving "hdfs" all the permissions in the KMS policy (did it on the Ranger web site
http://127.0.0.1:6080/index.html#!/service/6/policies/18/edit ), I got different error when copying files to the directory:
[hdfs@sandbox ~]$ cp test.txt /mnt/nfs/zone_plain/fromNFS.txt cp: cannot create regular file `/mnt/nfs/zone_plain/fromNFS.txt': Input/output error
On the other hand, read works:
[hdfs@sandbox ~]$ cat /mnt/nfs/zone_encr/test3.txt
Any suggestion?
Thanks
John Lee
Created 02-14-2016 04:07 PM
This can help to give some pointers to resolve this.
1) Support jira https://issues.apache.org/jira/browse/HDFS-7003 (TDE is supported with NFS)
2) Permission denied and I/O error https://issues.apache.org/jira/browse/HDFS-6411
3) It has hint to the problem link (The issue may not be related to TDE)
Created 01-20-2016 08:30 PM
Created 02-02-2016 09:22 PM
@john Lee are you still having problems with this? Can you provide your own solution or accept best answer?
Created 02-14-2016 03:53 PM
@Mark Herring no response since 02/02.
Created 02-14-2016 04:07 PM
This can help to give some pointers to resolve this.
1) Support jira https://issues.apache.org/jira/browse/HDFS-7003 (TDE is supported with NFS)
2) Permission denied and I/O error https://issues.apache.org/jira/browse/HDFS-6411
3) It has hint to the problem link (The issue may not be related to TDE)