Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
06-20-2016
12:36 AM
- last edited on
04-21-2026
06:51 AM
by
GrazittiAPI
I am developing and testing on Cloudera Quickstart, I have been doing so for about a month. Friday I was going to try some put methods on HBASE, but browsing from Hue I got these errors:
#Errors accessing Hue
hadoop.hdfs_clusters.default.webhdfs_url Current value: http://localhost:50070/webhdfs/v1 Failed to access filesystem root Hive Editor Failed to access Hive warehouse: /user/hive/warehouse Impala Editor No available Impalad to send queries to.
#Error accessing Hbase
Api Error: java.net.SocketTimeoutException: callTimeout=0, callDuration=203: at
[stack trace, I am omitting it]
at java.lang.Thread.run(Thread.java:745) Caused by: org.apache.hadoop.hbase.MasterNotRunningException: java.io.IOException: Can't get master address from ZooKeeper; znode data == null at
#From Hbase Log:
2016-06-19 12:06:39,306 INFO [quickstart:60000.activeMasterManager] Configuration.deprecation: fs.default.name is deprecated. Instead, use fs.defaultFS
2016-06-19 12:06:39,621 INFO [master/quickstart.cloudera/127.0.0.1:60000] regionserver.HRegionServer: ClusterId : 36bbf1ec-2337-4143-b2fb-fd933333cd8f
2016-06-19 12:06:40,510 FATAL [quickstart:60000.activeMasterManager] master.HMaster: Failed to become active master
java.net.ConnectException: Call From quickstart.cloudera/127.0.0.1 to quickstart.cloudera:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
[Stack trace again]
Created 06-23-2016 12:26 AM
The problem was with the FSImage file (the last one), which was corrupted and didn't allow the hdfs namenode service to start.
To understand if you have my same issue:
Hope this will save you time.
Created 06-23-2016 12:26 AM
The problem was with the FSImage file (the last one), which was corrupted and didn't allow the hdfs namenode service to start.
To understand if you have my same issue:
Hope this will save you time.