Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
05-06-2016
03:28 PM
- last edited on
04-21-2026
06:52 AM
by
GrazittiAPI
Hello
Why does Hue run Impala query as 'hue/master1@MY-REALM' instead my username 'ben'?
I get this error (even i'm logged-in as 'ben' user)
Your query has the following error(s):
Request from user 'hue/master1@MY-REALM' with requested pool 'it' denied access to assigned pool 'root.it'
Previous to Cloudera 5.7 i think Cloudera had llama service and ran Impala query as 'llama' user. Now with Cloudera 5.7 I could have Impala without llama and have it's own Dynamic Resource Management. but problem is Hue runs query as hue/master1... user instead of my username.
Similar thing happens to Hive. Hive runs hive query as 'hive' user instead of my username. I found it pretty annoying..
Does anyone has better idea to this?
Ben
Created 05-15-2016 08:51 PM
Created 05-09-2016 09:32 AM
Created 05-10-2016 08:01 AM
I added this configuration to Hue Server
[impala]
impersonation_enabled=True
Now i get this error
User 'hue/[email protected]' is not authorized to delegate to 'ben'. User delegation is disabled.
Created 05-15-2016 08:51 PM
Created 05-16-2016 09:17 AM
I have had authorized_proxy_user_config=hue=* configuration on CM, but for some reason it wasn't being populated on impalad configuration.
after reading the post you provided me, instead of manually adding it to "advanced snippet", I enabled Sentry Authorization on Impala. Now the configuration appears on the impalad, and impersonation works fine.
Thank you for your help Romain
Ben