Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-03-2016 04:45 PM
FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.DDLTask. MetaException(message:hdfs://quickstart.cloudera:8020/user/cloudera/emp1/emp.txt is not a directory or unable to create one)
Created 12-03-2016 05:21 PM
can you try create table like this
create external table emp1(eno int,
ename string,
sal string)
row format delimited
fields terminate by '~'
location '/tmp';
this will create a table with name emp1 on hdfs under /tmp location. seems you are following some cloudera documentation to create table on hdp platform but user cloudera won't exist on HDP thats why you are facing problem.
Created 12-03-2016 06:21 PM
you need to explicitly load data using load data inpath into table
Created 12-05-2016 12:24 AM
Thanks Raj