Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Infrastructure creation failed. Reason: Image creation failed because https://sequenceiqwesteurope2.blob.core.windows.net/images/hdc-hdp--1703101455.vhddoes not exist or Cloudbreak could not reach.

avatar
New Member

Immediately after starting the creation of my cluster the infrastructure creation fails due to a vhd file not found error:

4/19/2017 11:33:58 AM spark-dev - update in progress: Infrastructure creation failed. Reason: Image creation failed because https://sequenceiqwesteurope2.blob.core.windows.net/images/hdc-hdp--1703101455.vhddoes not exist or Cloudbreak could not reach.

However,

  • I created a similar cluster just weeks ago with the same setup
  • If I go into the Cloudbreak VM and try to get the vhd URI with wget, I can simply download the vhd file.

When I look in the Cloudbreak log, I see an additional error, just before the above:

"The Resource 'Microsoft.Storage/storageAccounts/cbstorewe5db978ee37d347a' under resource group 'cbstore' was not found."

When I look in Azure, I don't see this resource and I don't remember having seen it before.

I'm running Cloudbreak version 1.14.1-6ff7af8

What could cause this problem? Could it be the missing resource? If so, how could I recreate it?

1 ACCEPTED SOLUTION

avatar
New Member

It turned out that during moving the resources to another subscription, the storageaccount was inadvertently moved to another resource group. Moving it back solved the issue.

View solution in original post

2 REPLIES 2

avatar
New Member

It turned out that during moving the resources to another subscription, the storageaccount was inadvertently moved to another resource group. Moving it back solved the issue.

avatar
Expert Contributor

Hi @Peter Teunissen

I have checked and the image exist in the storage account, link to that:

https://sequenceiqwesteurope2.blob.core.windows.net/images/hdc-hdp--1703101455.vhd

Could it be possible that your deployment is not able to reach the vhd because of some custom security rule?

Have you tried install a cluster again maybe just some Azure service was unavailable that time?

Br,

Tamas