Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 07-24-2017 02:01 AM - edited 09-16-2022 04:58 AM
Hi, I am using HDP and Ambari for the 1st time and try to set up a three node cluster and facing the below error while installing the software at datanode install
stderr: Traceback (most recent call last): File "/var/lib/ambari-agent/cache/common-services/HDFS/2.1.0.2.0/package/scripts/datanode.py", line 174, in <module> DataNode().execute() File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 280, in execute method(env) File "/var/lib/ambari-agent/cache/common-services/HDFS/2.1.0.2.0/package/scripts/datanode.py", line 49, in install self.install_packages(env) File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 567, in install_packages retry_count=agent_stack_retry_count) File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 155, in __init__ self.env.run() File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run self.run_action(resource, action) File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action provider_action() File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 54, in action_install self.install_package(package_name, self.resource.use_repos, self.resource.skip_repos) File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py", line 49, in install_package self.checked_call_with_retries(cmd, sudo=True, logoutput=self.get_logoutput()) File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 83, in checked_call_with_retries return self._call_with_retries(cmd, is_checked=True, **kwargs) File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 91, in _call_with_retries code, out = func(cmd, **kwargs) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 71, in inner result = function(command, **kwargs) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 93, in checked_call tries=tries, try_sleep=try_sleep) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 141, in _call_wrapper result = _call(command, **kwargs_copy) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 294, in _call raise Fail(err_msg) resource_management.core.exceptions.Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install hadoop_2_5_6_0_40-client' returned 1. Error: Package: hadoop_2_5_6_0_40-hdfs-2.7.3.2.5.6.0-40.el6.x86_64 (HDP-2.5) Requires: libtirpc-devel You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest stdout: 2017-07-07 11:30:06,995 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf 2017-07-07 11:30:06,996 - Group['livy'] {} 2017-07-07 11:30:06,997 - Group['spark'] {} 2017-07-07 11:30:06,997 - Group['zeppelin'] {} 2017-07-07 11:30:06,997 - Group['hadoop'] {} 2017-07-07 11:30:06,997 - Group['users'] {} 2017-07-07 11:30:06,998 - User['hive'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']} 2017-07-07 11:30:06,998 - User['zookeeper'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']} 2017-07-07 11:30:06,999 - User['infra-solr'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']} 2017-07-07 11:30:06,999 - User['ams'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']} 2017-07-07 11:30:07,000 - User['tez'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'users']} 2017-07-07 11:30:07,000 - User['zeppelin'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']} 2017-07-07 11:30:07,001 - User['livy'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']} 2017-07-07 11:30:07,001 - User['spark'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']} 2017-07-07 11:30:07,002 - User['ambari-qa'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'users']} 2017-07-07 11:30:07,002 - User['hdfs'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']} 2017-07-07 11:30:07,003 - User['yarn'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']} 2017-07-07 11:30:07,003 - User['mapred'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']} 2017-07-07 11:30:07,003 - User['hcat'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']} 2017-07-07 11:30:07,004 - File['/var/lib/ambari-agent/tmp/changeUid.sh'] {'content': StaticFile('changeToSecureUid.sh'), 'mode': 0555} 2017-07-07 11:30:07,006 - Execute['/var/lib/ambari-agent/tmp/changeUid.sh ambari-qa /tmp/hadoop-ambari-qa,/tmp/hsperfdata_ambari-qa,/home/ambari-qa,/tmp/ambari-qa,/tmp/sqoop-ambari-qa'] {'not_if': '(test $(id -u ambari-qa) -gt 1000) || (false)'} 2017-07-07 11:30:07,010 - Skipping Execute['/var/lib/ambari-agent/tmp/changeUid.sh ambari-qa /tmp/hadoop-ambari-qa,/tmp/hsperfdata_ambari-qa,/home/ambari-qa,/tmp/ambari-qa,/tmp/sqoop-ambari-qa'] due to not_if 2017-07-07 11:30:07,011 - Group['hdfs'] {} 2017-07-07 11:30:07,011 - User['hdfs'] {'fetch_nonlocal_groups': True, 'groups': [u'hadoop', u'hdfs']} 2017-07-07 11:30:07,012 - FS Type: 2017-07-07 11:30:07,012 - Directory['/etc/hadoop'] {'mode': 0755} 2017-07-07 11:30:07,023 - File['/usr/hdp/current/hadoop-client/conf/hadoop-env.sh'] {'content': InlineTemplate(...), 'owner': 'hdfs', 'group': 'hadoop'} 2017-07-07 11:30:07,024 - Directory['/var/lib/ambari-agent/tmp/hadoop_java_io_tmpdir'] {'owner': 'hdfs', 'group': 'hadoop', 'mode': 01777} 2017-07-07 11:30:07,038 - Initializing 2 repositories 2017-07-07 11:30:07,038 - Repository['HDP-2.5'] {'base_url': 'http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.5.6.0', 'action': ['create'], 'components': [u'HDP', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'HDP', 'mirror_list': None} 2017-07-07 11:30:07,045 - File['/etc/yum.repos.d/HDP.repo'] {'content': '[HDP-2.5]\nname=HDP-2.5\nbaseurl=http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.5.6.0\n\npath=/\nenabled=1\ngpgcheck=0'} 2017-07-07 11:30:07,046 - Repository['HDP-UTILS-1.1.0.21'] {'base_url': 'http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.21/repos/centos7', 'action': ['create'], 'components': [u'HDP-UTILS', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'HDP-UTILS', 'mirror_list': None} 2017-07-07 11:30:07,048 - File['/etc/yum.repos.d/HDP-UTILS.repo'] {'content': '[HDP-UTILS-1.1.0.21]\nname=HDP-UTILS-1.1.0.21\nbaseurl=http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.21/repos/centos7\n\npath=/\nenabled=1\ngpgcheck=0'} 2017-07-07 11:30:07,049 - Package['unzip'] {'retry_on_repo_unavailability': False, 'retry_count': 5} 2017-07-07 11:30:07,170 - Skipping installation of existing package unzip 2017-07-07 11:30:07,171 - Package['curl'] {'retry_on_repo_unavailability': False, 'retry_count': 5} 2017-07-07 11:30:07,205 - Skipping installation of existing package curl 2017-07-07 11:30:07,205 - Package['hdp-select'] {'retry_on_repo_unavailability': False, 'retry_count': 5} 2017-07-07 11:30:07,238 - Skipping installation of existing package hdp-select 2017-07-07 11:30:07,400 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf 2017-07-07 11:30:07,401 - Stack Feature Version Info: stack_version=2.5, version=None, current_cluster_version=None -> 2.5 2017-07-07 11:30:07,415 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf 2017-07-07 11:30:07,425 - checked_call['rpm -q --queryformat '%{version}-%{release}' hdp-select | sed -e 's/\.el[0-9]//g''] {'stderr': -1} 2017-07-07 11:30:07,453 - checked_call returned (0, '2.5.6.0-40', '') 2017-07-07 11:30:07,457 - Package['hadoop_2_5_6_0_40'] {'retry_on_repo_unavailability': False, 'retry_count': 5} 2017-07-07 11:30:07,575 - Skipping installation of existing package hadoop_2_5_6_0_40 2017-07-07 11:30:07,576 - Package['hadoop_2_5_6_0_40-client'] {'retry_on_repo_unavailability': False, 'retry_count': 5} 2017-07-07 11:30:07,610 - Installing package hadoop_2_5_6_0_40-client ('/usr/bin/yum -d 0 -e 0 -y install hadoop_2_5_6_0_40-client') Command failed after 1 tries
Any suggestions on how to proceed forward with this.
Created 07-24-2017 02:02 AM
We see that you are getting the following error when Ambari is trying to install hadoop from yum repo. It requires "libtirpc-devel" package to be already installed on your host which should come from Operating System repo.
Execution of '/usr/bin/yum -d 0 -e 0 -y install hadoop_2_5_6_0_40-client' returned 1. Error: Package: hadoop_2_5_6_0_40-hdfs-2.7.3.2.5.6.0-40.el6.x86_64 (HDP-2.5) Requires: libtirpc-devel You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest
- Can you please make sure that the mentioned package "libtirpc-devel" is already installed on your host. You can have a look at the similar post: https://community.hortonworks.com/questions/101877/hdp-2603-install-fails-on-rhel-68-ambari-250-libt...
.
Created 07-24-2017 02:02 AM
We see that you are getting the following error when Ambari is trying to install hadoop from yum repo. It requires "libtirpc-devel" package to be already installed on your host which should come from Operating System repo.
Execution of '/usr/bin/yum -d 0 -e 0 -y install hadoop_2_5_6_0_40-client' returned 1. Error: Package: hadoop_2_5_6_0_40-hdfs-2.7.3.2.5.6.0-40.el6.x86_64 (HDP-2.5) Requires: libtirpc-devel You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest
- Can you please make sure that the mentioned package "libtirpc-devel" is already installed on your host. You can have a look at the similar post: https://community.hortonworks.com/questions/101877/hdp-2603-install-fails-on-rhel-68-ambari-250-libt...
.
Created 07-25-2017 02:13 PM
I fixed it last week, i was using redhat 7.3 and was missing the libtripc-devel package. Below is what i did
yum install libtirpc-devel-0.2.4-0.8.el7_3.i686.rpm
after that i had to reset ambari
ambari-server reset
and start it back. once started successfully i started over setting up from the 1st step.