Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 04-06-2018 06:17 AM - edited 09-16-2022 06:04 AM
Hello Cloudera Community,
I'm trying to intall cloudera manager in debian 8 jessie OS, and during the processing of the installation by running the cloudera-manager-installer.bin i had this error
*Then i checked the log file mentionned in the error message , i had this :
Job for cloudera-scm-server-db.service failed. See 'systemctl status cloudera-scm-server-db.service' and 'journalctl -xn' for details.
*To know more about the error , i run the command mentioned in the log file ,and i had this :
● cloudera-scm-server-db.service - LSB: Cloudera SCM Server's Embedded DB
Loaded: loaded (/etc/init.d/cloudera-scm-server-db)
Active: failed (Result: exit-code) since ven. 2018-04-06 15:05:06 CEST; 6min ago
Process: 29977 ExecStart=/etc/init.d/cloudera-scm-server-db start (code=exited, status=1/FAILURE)
avril 06 15:05:06 SRVSTGHOST runuser[29987]: pam_unix(runuser:session): session opened for user cloudera-scm by (uid=0)
avril 06 15:05:06 SRVSTGHOST cloudera-scm-server-db[29977]: initdb : nom de locale invalide (« en_US.UTF8 »)
avril 06 15:05:06 SRVSTGHOST runuser[29987]: pam_unix(runuser:session): session closed for user cloudera-scm
avril 06 15:05:06 SRVSTGHOST cloudera-scm-server-db[29977]: Les ... failed!
avril 06 15:05:06 SRVSTGHOST systemd[1]: cloudera-scm-server-db.service: control process exited, code=exited status=1
avril 06 15:05:06 SRVSTGHOST systemd[1]: Failed to start LSB: Cloudera SCM Server's Embedded DB.
avril 06 15:05:06 SRVSTGHOST systemd[1]: Unit cloudera-scm-server-db.service entered failed state.
Any help would be appreciated.
Created 04-10-2018 06:41 AM
Created 04-09-2018 02:35 AM
Can anyone help me please ?
Created 04-09-2018 06:53 AM
Hi Youssef,
Well, that error message isn't very helpful. Let me try this myself. I assume you are running on Debian 8.9 and trying to install Cloudera Manager 5.14.1.
Tina
Created on 04-09-2018 06:57 AM - edited 04-09-2018 07:25 AM
Hello Tina,
Thank you for you message . Definitely i'm trying to install CDH in debian 8.4 .If that error isn't much helpful i can show more .
Youssef
Created 04-09-2018 08:43 AM
Hi,
I just did an install on Debian 8.4 and it worked. My exact commands.
wget https://archive.cloudera.com/cm5/installer/latest/cloudera-manager-installer.bin
chmod 777 cloudera-manager-installer.bin
./cloudera-manager-installer.bin
Try looking at all the install logs in /var/log/cloudera-manager-installer/
Maybe one of these logs will show you why the PostgreSQL database is not installing correctly or starting.
Tina
Created 04-09-2018 10:16 AM
(1)
Make sure you have selinux disabled. cloudera-scm-server-db will fail much like you showed if selinux is enforcing.
(run sestatus to check status)
(2)
Check /var/log/cloudera-scm-server/db.log
It may have more failure info
(3)
Check /var/lib/cloudera-scm-server-db/data/pg_log
It may have files containing information regarding failures of some sort.
Created 04-10-2018 02:53 AM
Hello,
I tried to remove all cloudera files and uninstall postgresql database and i checked the selinux ,which is disabled ,after that i started from the beginning as tina mentionned is the message , but i still have the same problem;the installation failed to start Embedded Service and configuration Database .
Created on 04-10-2018 04:14 AM - edited 04-10-2018 12:46 PM
Process: 29977 ExecStart=/etc/init.d/cloudera-scm-server-db start (code=exited, status=1/FAILURE) avril 06 15:05:06 SRVSTGHOST runuser[29987]: pam_unix(runuser:session): session opened for user cloudera-scm by (uid=0) avril 06 15:05:06 SRVSTGHOST cloudera-scm-server-db[29977]: initdb : nom de locale invalide (« en_US.UTF8 »)
The error _may be_ related to the embedded PostgreSQL our script is using, as this is _not_ a common message to see.
The script (initialize_embedded_db.sh) attempts to initialise embedded PostgreSQL using the 'initdb' command [3] and the command is failing with the following message "initdb : nom de locale invalide (« en_US.UTF8 »)".
- How is your Debian locale configured as [0]?
- Have you made any locale changes recently [1]?
- Also review the topic "22.1.3. Problems" in [2] using the steps I've provided below.
e.g.: testing this command succeeded in my node - see [3] for what each parameter represent
sudo -u cloudera-scm echo -n "password" > /tmp/generated_password.txt
sudo -u cloudera-scm initdb --pgdata "/some_tmp/folder/to/test/data" --encoding=UTF8 --locale=en_US.UTF8 --auth=md5 --username="cloudera-scm" --pwfile="/tmp/generated_password.txt"
[0] https://wiki.debian.org/Locale ; see "dpkg-reconfigure locales"
[1] https://serverfault.com/a/491502
[2] https://www.postgresql.org/docs/9.5/static/locale.html
[3] https://www.postgresql.org/docs/9.5/static/app-initdb.html
Created 04-10-2018 06:41 AM
Created 04-10-2018 06:57 AM