Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 04-19-2017 09:02 PM
I have recently installed the SmartSense version 1.3.1.0-136 component in my HDP stack.
When performing a manual capture, I discovered the bundle contains information for only one node, the HST-Server.
The hst-server logs roll through a series of Java errors:
19 Apr 2017 11:54:47,041 WARN [pool-1-thread-1] UploadRunnable:152 - Exception type encountered : Unable to reach hortonworks.com:80. Please verify outbound connectivity on Gateway.
19 Apr 2017 11:54:47,042 INFO [pool-1-thread-1] UploadRunnable:161 - Waiting for 50000 milliseconds before next retry attempt.
19 Apr 2017 11:55:37,042 INFO [pool-1-thread-1] UploadRunnable:171 - Retry Attempt :10
19 Apr 2017 11:55:37,042 INFO [pool-1-thread-1] UploadRunnable:197 - Retrying File Upload.
19 Apr 2017 11:55:37,043 INFO [pool-1-thread-1] UploadRunnable:208 - Starting encryption for uploading bundle.
19 Apr 2017 11:55:37,044 INFO [pool-1-thread-1] GatewayConfigValidator:67 - Found configurations to be used for connectivity.
19 Apr 2017 11:55:37,044 INFO [pool-1-thread-1] GatewayValidator:149 - Trying to reach: smartsense.hortonworks.com:443
19 Apr 2017 11:55:37,046 ERROR [pool-1-thread-1] GatewayValidator:93 - Failed to reach SmartSense landing zone host: smartsense.hortonworks.com, port:443
19 Apr 2017 11:55:37,046 INFO [pool-1-thread-1] GatewayValidator:149 - Trying to reach: hortonworks.com:80
19 Apr 2017 11:55:37,048 ERROR [pool-1-thread-1] GatewayValidator:100 - Failed to reach hortonworks.com:80.
19 Apr 2017 11:55:37,048 ERROR [pool-1-thread-1] GatewayEmbeddedClient:134 - Failed during upload bundle :
com.hortonworks.smartsense.gateway.GatewayException: Unable to reach hortonworks.com:80. Please verify outbound connectivity on Gateway.
at com.hortonworks.smartsense.gateway.server.GatewayValidator.validateReachable(GatewayValidator.java:102)
at com.hortonworks.smartsense.gateway.server.GatewayValidator.validateSetup(GatewayValidator.java:65)
at com.hortonworks.smartsense.gateway.client.GatewayEmbeddedClient.validateSetup(GatewayEmbeddedClient.java:123)
at com.hortonworks.smartsense.gateway.client.GatewayEmbeddedClient.uploadBundle(GatewayEmbeddedClient.java:77)
at com.hortonworks.support.tools.gateway.UploadRunnable.uploadBundle(UploadRunnable.java:133)
at com.hortonworks.support.tools.gateway.UploadRunnable.retryUploadBundle(UploadRunnable.java:198)
at com.hortonworks.support.tools.gateway.UploadRunnable.uploadBundle(UploadRunnable.java:173)
at com.hortonworks.support.tools.gateway.UploadRunnable.retryUploadBundle(UploadRunnable.java:198)
at com.hortonworks.support.tools.gateway.UploadRunnable.uploadBundle(UploadRunnable.java:173)
at com.hortonworks.support.tools.gateway.UploadRunnable.retryUploadBundle(UploadRunnable.java:198)
at com.hortonworks.support.tools.gateway.UploadRunnable.uploadBundle(UploadRunnable.java:173)
at com.hortonworks.support.tools.gateway.UploadRunnable.retryUploadBundle(UploadRunnable.java:198)
at com.hortonworks.support.tools.gateway.UploadRunnable.uploadBundle(UploadRunnable.java:173)
at com.hortonworks.support.tools.gateway.UploadRunnable.retryUploadBundle(UploadRunnable.java:198)
at com.hortonworks.support.tools.gateway.UploadRunnable.uploadBundle(UploadRunnable.java:173)
at com.hortonworks.support.tools.gateway.UploadRunnable.retryUploadBundle(UploadRunnable.java:198)
at com.hortonworks.support.tools.gateway.UploadRunnable.uploadBundle(UploadRunnable.java:173)
at com.hortonworks.support.tools.gateway.UploadRunnable.retryUploadBundle(UploadRunnable.java:198)
at com.hortonworks.support.tools.gateway.UploadRunnable.uploadBundle(UploadRunnable.java:173)
at com.hortonworks.support.tools.gateway.UploadRunnable.retryUploadBundle(UploadRunnable.java:198)
at com.hortonworks.support.tools.gateway.UploadRunnable.uploadBundle(UploadRunnable.java:173)
at com.hortonworks.support.tools.gateway.UploadRunnable.retryUploadBundle(UploadRunnable.java:198)
at com.hortonworks.support.tools.gateway.UploadRunnable.uploadBundle(UploadRunnable.java:173)
at com.hortonworks.support.tools.gateway.UploadRunnable.retryUploadBundle(UploadRunnable.java:198)
at com.hortonworks.support.tools.gateway.UploadRunnable.uploadBundle(UploadRunnable.java:173)
at com.hortonworks.support.tools.gateway.UploadRunnable.run(UploadRunnable.java:221)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.net.UnknownHostException: smartsense.hortonworks.com
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:589)
at com.hortonworks.smartsense.gateway.server.GatewayValidator.isReachable(GatewayValidator.java:150)
at com.hortonworks.smartsense.gateway.server.GatewayValidator.validateReachable(GatewayValidator.java:90)
... 30 more
These errors are to be expected as external network connectivity is not present within my environment. I have not experienced similar problems when using a previous version of SmartSense. Manual bundle uploads are preferred. I understand the benefits of a Gateway node, but I simply don't want to configure one.
Hortonworks SmartSense documentation and conversations within this forum assume the desired use of a Gateway node. Ambari configurations for SmartSense do not provide an option to disable the Gateway. One method that I found to remove the Gateway results in completely uninstalling the HST service.
I greatly appreciate any information or support that the Hortonworks Community can provide.
Created 04-20-2017 07:58 AM
Add the below attribute under custom hst-server-conf section via Ambari:
gateway.enabled = false
HST-Server Log Output (/var/log/hst/hst-server.log):
20 Apr 2017 03:49:38,969 INFO [Thread-1] UploadActionHelper:46 - Gateway is disabled for auto upload.
Created 04-20-2017 07:58 AM
Add the below attribute under custom hst-server-conf section via Ambari:
gateway.enabled = false
HST-Server Log Output (/var/log/hst/hst-server.log):
20 Apr 2017 03:49:38,969 INFO [Thread-1] UploadActionHelper:46 - Gateway is disabled for auto upload.