Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-21-2017 06:09 AM
While granting user permission in HBase, it is failing with error. Recently we have de-kerberized and kerberized the Cluster.
"ERROR ArgumentError: DISABLED: Security features are not available"
Created 03-22-2017 08:37 AM
That seems to be a bug, let's disable the ACL for ZK, by adding below in zookeeper-env.sh -Dzookeeper.skipACL=yes
1) Stop HBase
2) Add -Dzookeeper.skipACL=yes in zookeeper-env.sh
export SERVER_JVMFLAGS="$SERVER_JVMFLAGS -Dzookeeper.skipACL=yes -Djava.security.auth.login.config={{zk_server_jaas_file}}"
3) rmr /hbase-secure/table/hbase:acl
4)revert back the change in step 2 -Dzookeeper.skipACL=yes
5) Restart HBase again
6) Try grant it should work now
Created 03-21-2017 06:12 AM
Hi @prsingh Are you able to create and list hbase tables? Also HBase UI is working fine? Can you also confirm if Ranger is enabled?
Created 03-21-2017 06:15 AM
@nyadav
Yes, I'm able to create and list table from shell. Only issue is while granting permission.
Also Ranger is not enabled.
Created 03-21-2017 08:55 AM
Thanks. Let's remove the acl znode from the ZK. Stop HBase services, and follow below steps
--login to zkcli (hbase zkcli) -- rmr /hbase-secure/table/hbase:acl
Created 03-22-2017 06:19 AM
I am getting below exception while running the below command,
rmr /hbase-secure/table/hbase:acl
Authentication is not valid : /hbase-secure/table/hbase:acl
Created 03-22-2017 08:37 AM
That seems to be a bug, let's disable the ACL for ZK, by adding below in zookeeper-env.sh -Dzookeeper.skipACL=yes
1) Stop HBase
2) Add -Dzookeeper.skipACL=yes in zookeeper-env.sh
export SERVER_JVMFLAGS="$SERVER_JVMFLAGS -Dzookeeper.skipACL=yes -Djava.security.auth.login.config={{zk_server_jaas_file}}"
3) rmr /hbase-secure/table/hbase:acl
4)revert back the change in step 2 -Dzookeeper.skipACL=yes
5) Restart HBase again
6) Try grant it should work now