Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-07-2017 01:32 PM
When I'm trying to test an (express) upgrade of a stack including my custom component I get the following error:
Last Service Check should be more recent than the last configuration change for the given service
Reason: Unexpected server error happenedFailed on:
As you can see, it doesn't tell me which component. Anyhow, as I'm having my own component installed with the stack I suppose it's my own.
My colleague now pointed out that it's maybe because I do not have a "Config" tab in my component. Could this be the issue?
To shortly explain what my service does: I want to be able to have 2+ RegionServers on one host, thus I just copy the configuration from the original RegionServer and just do some changes within two configuration files before the component gets started. That's why I do not need any configuration within Ambari itself.
Hopefully somebody can explain a bit about my issue. Thanks
Created 08-08-2017 08:29 AM
If you are sure its related to your Custom Service ,
You can skip the service checks of Ambari before upgrade by changing the configuration in ambari.properties :
cd /etc/ambari-server/conf vi ambari.properties
check for the below configurations (add if doesnt exist):
skip.service.checks=true -- if you want to skip service checks stack.upgrade.bypass.prechecks=true
Restart the ambari server
Perform the steps.
It has to work fine.
Let me know if it works
Created 08-08-2017 08:29 AM
If you are sure its related to your Custom Service ,
You can skip the service checks of Ambari before upgrade by changing the configuration in ambari.properties :
cd /etc/ambari-server/conf vi ambari.properties
check for the below configurations (add if doesnt exist):
skip.service.checks=true -- if you want to skip service checks stack.upgrade.bypass.prechecks=true
Restart the ambari server
Perform the steps.
It has to work fine.
Let me know if it works
Created 08-09-2017 11:57 AM
Thanks for your answer @Akhil S Naik.
It seems that it really was the issue with the config. I now changed my service to contain a config, although it's not used, but I don't have the issue anymore.
Nevertheless, I didn't test the ambari-server configuration change, as it would have only been a workaround for me.