Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Joining a node to a NiFi cluster fails because of duplicate node id

avatar
Guru

When adding a node to a NiFi cluster, I receive an error saying the NCM prevented connection due to the node id already existing.

1 ACCEPTED SOLUTION

avatar
Guru

This was resolved by removing the state directory in the node.

The node was originally configured with incorrect hostnames copied from an existing node's nifi.properties, which led the generation of an incorrect nodeid and storage in state. When the host settings were corrected the node id persisted in the state folder. Removing this folder corrected the problem and allowed the node to be joined to the cluster correctly.

View solution in original post

2 REPLIES 2

avatar
Guru

This was resolved by removing the state directory in the node.

The node was originally configured with incorrect hostnames copied from an existing node's nifi.properties, which led the generation of an incorrect nodeid and storage in state. When the host settings were corrected the node id persisted in the state folder. Removing this folder corrected the problem and allowed the node to be joined to the cluster correctly.

avatar

Thanks for putting this out Simon! We definitely need to make this something people don't need to think about. Ideas welcome.