Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Kerberized HDP 2.4 - not able to access Hive View

avatar
Expert Contributor
screen-shot-2016-12-01-at-110317-am.pnghdp24-core-site-notworking.xml

Hi All,

I've kerberized HDP 2.4, and i'm trying to access Hive view on Ambari.

I'm logged in as admin, and i'm getting the following error -

-----------

Failed on local exception: java.io.IOException: org.apache.hadoop.security.AccessControlException: Client cannot authenticate via:[TOKEN, KERBEROS]; Host Details : local host is: "sandbox.hortonworks.com/10.0.2.15"; destination host is: "sandbox.hortonworks.com":8020;

---------------

I've followed the steps in the following link -

https://community.hortonworks.com/articles/40658/configure-hive-view-for-kerberized-cluster.html

Pls note - I'm able to access the Tez view, but the Hive view is showing exception

Attached is screenshot of Hive View, and core-site.xml.

1 ACCEPTED SOLUTION

avatar
Master Guru
@Karan Alang

I can see that you have mentioned IP address under custom settings. Please do not use IP addresses anywhere, Kerberos authentication doesn't like IP addresses.

Also Please select custom setting where you have selected local cluster under 'Cluster Management' section.

I would suggest you double check the settings with my article. I can see that YARN resource manager and ATS properties are also unset in your PDF.

Hope this information helps.

View solution in original post

10 REPLIES 10

avatar
Expert Contributor

@Kuldeep Kulkarni - could you pls take a look, and let me know.. i've sone the steps provided in you post, but still getting the error.

https://community.hortonworks.com/articles/40658/configure-hive-view-for-kerberized-cluster.html

Thanks !

avatar
Master Guru

@Karan Alang - Can you please confirm if you have configured Ambari for Kerberos authentication?

Can you please paste me the screenshot of your hive view settings? also if possible please attach ambari-server.log to this thread.

avatar
Expert Contributor
ambari-hive-view-hdp24.pdf

@Kuldeep Kulkarni - yes, used the following link to configure Ambari for Kerberos

https://community.hortonworks.com/articles/40635/configure-tez-view-for-kerberized-hdp-cluster.html

also, attached is ambari-server.log & the screenshot of the Hive View on Ambari

Pls let me know, thanks !ambari-server-1201log.zip

avatar
Expert Contributor

@Kuldeep Kulkarni,

btw, i'm running Hive on MapReduce (was getting error on running on Tez)

avatar
Expert Contributor

screen-shot-2016-12-01-at-113647-am.png

screen-shot-2016-12-01-at-113656-am.png

Attaching screenshots of the Hive View configuration on Ambari.

avatar
Master Guru
@Karan Alang

I can see that you have mentioned IP address under custom settings. Please do not use IP addresses anywhere, Kerberos authentication doesn't like IP addresses.

Also Please select custom setting where you have selected local cluster under 'Cluster Management' section.

I would suggest you double check the settings with my article. I can see that YARN resource manager and ATS properties are also unset in your PDF.

Hope this information helps.

avatar
Expert Contributor

@Kuldeep Kulkarni,

thanks for the input .. using the Custom setting (with changed values) instead of the default 'local cluster' seems to have fixed the issue !

avatar
Expert Contributor

@Kuldeep Kulkarni - i seem to be having another issue .. i've users (hive_user1, hive_user2) and i've created policy giving the access to table - test.

On trying to access the table on Hive View, it gives the following error ->

-----------------

Error while compiling statement: FAILED: HiveAccessControlException Permission denied: user [ambari-server] does not have [SELECT] privilege on [default/test/sno] [ERROR_STATUS]

----------------

Details in the link below ->

https://community.hortonworks.com/questions/69761/kerberized-hdp-24-getting-error-in-using-hive-view...

what needs to be done to fix this issue ?

Thanks !

avatar
Master Guru

@Karan Alang - Can you please check if you have ranger plugin enabled for Hive? If so, please try to grant ambari-server access to default DB