Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Hello !
After some work I finished setting up Cloudera + MIT Kerberos + Windows AD.
from linux machine, I'm able to run "kinit ben@WIN-REALM" and then access hadoop or visit namenode webadmin. Of course I did configure SPNEGO on the web browser.
However, after logging in to my windows machine, which authenticate through windows AD, I can't access namenode webadmin which is at http://namenode:50070.
I tried running kinit from CMD but nothing changes.
this is what i get when i visit namenode webadmin.
HTTP ERROR 403
Problem accessing /index.html. Reason:
GSSException: Defective token detected (Mechanism level: GSSHeader did not find the right tag)
what extra configuration do i need to do on windows to access hadoop webadmin page?
thank you!
Ben
Powered by Jetty://
Created 09-22-2015 09:29 AM
to answer my own question
I need to run this on windows cmd
ksetup /addkdc <REALM> <KDC hostname>
ksetup /addhosttorealmmap <httpFS hostname> <REALM>
and set SPNEGO settings on browser
Created on 01-01-2020 10:39 AM - edited 01-01-2020 10:47 AM
Hey sparamas,
How did you over come the below error and successfully executed the ksetup commands:
Failed to create Kerberos key: 5 (0x5)
Failed to open Kerberos Key: 0x5
Failed /AddKdc : 0xc0000001
Thanks
Created 03-03-2020 09:30 PM
Could you run the administrator cmd not a normal one?
From your error, I think you have not enough privilege to run these commands.