Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 10-22-2018 07:38 AM
llap-error.txtHello Team,
I have setup HDP 3.0 single node cluster with hive llap since few months backup. LLAP functionality is working fine. recently we have restarted the cluster and we are unable bring back to LLAP daemon online. we have checked RM ui and LLAP0 app is in running state. but still hiveserverinteractive process failing to start in ambari console. i have attached the log file below. please refer and help me to resolve the issue here ?
Thank you in Advance.
Created 10-22-2018 09:31 AM
we have found the issue with LLAP daemon port binding in LLAP app container logs. after killed the background llap java process we are able to start the hiveserverIntercative process sucessfully
Created 10-22-2018 09:31 AM
we have found the issue with LLAP daemon port binding in LLAP app container logs. after killed the background llap java process we are able to start the hiveserverIntercative process sucessfully
Created 02-13-2019 02:07 PM
capture-decran-2019-02-12-a-185811.pngHi,
Could you explain further please? I have the same problem.
When I restart HiveServer2 Interactive via Ambari, the later starts a yarn application named llap0 and still running a moment before it fails.
When I check via CLI :
hive --service llapstatus --name llap0
I get :
SLF4J: Class path contains multiple SLF4J bindings. SLF4J: Found binding in [jar:file:/usr/hdp/3.0.1.0-187/hive/lib/log4j-slf4j-impl-2.10.0.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: Found binding in [jar:file:/usr/hdp/3.0.1.0-187/hadoop/lib/slf4j-log4j12-1.7.25.jar!/org/slf4j/impl/StaticLoggerBinder.class] SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation. SLF4J: Actual binding is of type [org.apache.logging.slf4j.Log4jLoggerFactory] WARN conf.HiveConf: HiveConf of name hive.stats.fetch.partition.stats does not exist WARN conf.HiveConf: HiveConf of name hive.heapsize does not exist LLAPSTATUS -------------------------------------------------------------------------------- LLAP status unknown. Awaiting app launch -------------------------------------------------------------------------------- LLAP status unknown. Awaiting app launch -------------------------------------------------------------------------------- { "state" : "APP_NOT_FOUND", "runningThresholdAchieved" : false }
But on the Yarn Applications dashboard, the llap0 is in Running state (see attached picture).
Thanks.