Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-11-2016 02:32 PM
I have putfile processor. Input directory "X:\ab\${path}" for recurse puting files and set max file count in input directory 10000, but it still writing there, not going to failed. Why? But when setting X:\ab\ whithout ${path} it works, but i need it. Any Ideas??
Created on 08-12-2016 03:09 PM - edited 08-18-2019 03:29 AM
Make sure you define the Auto terminate relationship properly and handled the exception in the PutFile processor. Make sure to route the failed message to failure queue.
You should able to see the following exception in the log.
2016-08-12 11:02:41,628 INFO [Timer-Driven Process Thread-10] o.a.nifi.processors.standard.PutFile PutFile[id=4540b2c4-9425-4817-a7e1-d9d2930a2d5b] Penalizing StandardFlowFileRecord[uuid=51e1f6cb-3a31-42e3-bd65-1f6a1f20eff0,claim=StandardContentClaim [resourceClaim=StandardResourceClaim[id=1471013498033-1, container=default, section=1], offset=23989, length=806],offset=0,name=903851051716952,size=806] and routing to 'failure' because the output directory /Users/mpandit/test has 2 files, which exceeds the configured maximum number of files
Created on 08-12-2016 03:09 PM - edited 08-18-2019 03:29 AM
Make sure you define the Auto terminate relationship properly and handled the exception in the PutFile processor. Make sure to route the failed message to failure queue.
You should able to see the following exception in the log.
2016-08-12 11:02:41,628 INFO [Timer-Driven Process Thread-10] o.a.nifi.processors.standard.PutFile PutFile[id=4540b2c4-9425-4817-a7e1-d9d2930a2d5b] Penalizing StandardFlowFileRecord[uuid=51e1f6cb-3a31-42e3-bd65-1f6a1f20eff0,claim=StandardContentClaim [resourceClaim=StandardResourceClaim[id=1471013498033-1, container=default, section=1], offset=23989, length=806],offset=0,name=903851051716952,size=806] and routing to 'failure' because the output directory /Users/mpandit/test has 2 files, which exceeds the configured maximum number of files
Created 08-16-2016 04:04 PM
Yes, I did this, but my output directory is d:/abc/${path}