Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Memory corruption error while starting any service from ambari UI

avatar
New Member

Hi,

When I am starting any service from ambari UI, I am getting below error .. Any pointers on how to fix it? My entire cluster is down as I am not able to start any service because of this error

Ambari version is 2.1.2.1 and hdp version is 2.3

983-screenshot-tuesday-22-december-2015-122305-ist.png

1 ACCEPTED SOLUTION

avatar
New Member

Hi,

A quick upgrade to glibc has fixed the issue 🙂

Abhinav

 

View solution in original post

6 REPLIES 6

avatar
Master Mentor

avatar
New Member

I would check ulimit/top for number of open file handles (any leak over there) or memory consumption by any other process on the machine.

@abhinav s

avatar
New Member

Hi,

Soft limit is set to 1024 and hard limit is set to 4096, (I know its not HDP recommended)

avatar
Master Mentor

@abhinav s can you paste errors from ambari logs?

avatar
New Member

Hi,

A quick upgrade to glibc has fixed the issue 🙂

Abhinav

 

avatar

Hi, I agree with the solution, however, use tail -f /var/log/ambari-server/ambari-server.log to watch the logs while you try to start the service from the UI. This will give you real-time feedback.