Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 09-08-2017 11:30 AM
Env: HDP 2.6
Kerberos enabled
Atlas added as a service post upgrade.
Metadata is not visible from Atlas UI. Tried consuming the messages from beginning for the topic ATLAS_HOOK and this doesn't have any messages.
However, I can see the list of entities and when queried for the entities, I can see them in kafka-logs (grep with entity name and result shows the recent .log files matches).
Ranger plugin for kafka is not eabled and shen searched for ACL's, all users have write access from all hosts for the topic.
Created 09-09-2017 02:50 PM
@sundara Palanki
which entities types of entities you are referring to, if hive did you try import-hive.sh script or create table in hive db.
check the hive and atlas application logs for error during table creation time.
Created 09-08-2017 01:14 PM
You should enable the Ranger Kafka hook,restart all stale configs and retry
Created 09-08-2017 01:27 PM
@Geoffrey Shelton Okot The authorizer class is set to simpleAuthorizer* and why should I have the ranger plugin for kafka enabled ?
Created 09-09-2017 02:50 PM
@sundara Palanki
which entities types of entities you are referring to, if hive did you try import-hive.sh script or create table in hive db.
check the hive and atlas application logs for error during table creation time.
Created 09-11-2017 01:56 PM
@Nixon Rodrigues The problem was with the initial import where atlas user doesn't have read/execute on /apps/hive/warehouse. Once I added the policy for atlas user and ran the script, I was able to get everything in place.